LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error 200428 When Creating Task in DAQmx Base

Solved!
Go to solution
Highlighted

I've written a basic program that captures a voltage signal, plots it, and writes it to a file, but when I run it, I keep getting this error:

 

"Error -200428 occurred at Value passed to the Task/Channels In control is invalid."

 

I have attached a copy of my VI. Initially, I did not have the "DAQmx Base Create Task" VI in the block diagram and I was getting the above error. After searching through some documentation, it seemed that the issue was that I needed to put the "Create Task" VI in when using DAQmx Base. Unfortunately when I did that, I still kept getting the same error.


Is there something I am doing wrong here?

 

Here are my software/hardware information:

 

Operating Software: Mac OS X 10.11.14

Hardware: NI myDAQ

Software: LabVIEW 15.0 (64-bit)

Drivers: NI DAQmx Base 15, NI VISA 15.5, NI-488.2 15.5, NI-DAQmx for myDAQ on Mac OS X (all for OS X)

0 Kudos
Message 1 of 3
(2,020 Views)
Highlighted

Hi,

    Before going for further stpes kindly go through the link http://www.ni.com/product-documentation/2835/en/  to get good knowledge on development of Daq. hope this is helpfull.

 

The issue is with the input , an invalid input is givin to the daq mx vi. go through the link so that you will be able to solve it.

 

kudos Welcome 😄

 

 

Certified-LabVIEW-Associate-Dev_rgb (1).jpg

Certified LabVIEW Developer
Best LabVIEW Programmer @NIDAYS 2015
0 Kudos
Message 2 of 3
(1,988 Views)
Highlighted
Solution
Accepted by topic author AliMoradi

AliMoradi wrote:

 

I've written a basic program that captures a voltage signal, plots it, and writes it to a file, but when I run it, I keep getting this error:

 

"Error -200428 occurred at Value passed to the Task/Channels In control is invalid."

 

<snip>

 

Here are my software/hardware information:

 

Operating Software: Mac OS X 10.11.14

Hardware: NI myDAQ

Software: LabVIEW 15.0 (64-bit)

Drivers: NI DAQmx Base 15, NI VISA 15.5, NI-488.2 15.5, NI-DAQmx for myDAQ on Mac OS X (all for OS X)


Hi Ali.

 

You are encountering that error because NI-DAQmx Base does not support the NI-myDAQ device. You do have NI-DAQmx for myDAQ installed, however, which does support that device.

 

See the instructions here to confirm that the device and driver are communicating correctly:

 

Getting Started With NI-DAQmx for myDAQ on Mac OS X

http://www.ni.com/tutorial/52345/en/

Joe Friedchicken
NI Modular Instruments Application Software
Get with your fellow OS users
[ Linux ] [ macOS ]
Principal Software Engineer :: Modular Instruments Application Software
Senior Software Engineer :: Multifunction Instruments Applications Group (until May 2018)
Software Engineer :: Measurements RLP Group (until Mar 2014)
Applications Engineer :: High Speed Product Group (until Sep 2008)
0 Kudos
Message 3 of 3
(1,959 Views)