LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error 200279

Solved!
Go to solution
Highlighted

I am a labview novice. I have a few problems with the VI attached, I would really appreciate some expert user comments on the following issues: (note, there are a range of subVIs from instruments which I haven’t attached)

 

  • Major issue: Error -200279: Unable to Keep Up with Acquisition in DAQmx: I keep getting this error after the VI runs for 1 or 2 mins, it once also crushed. I’m planning of reading (and writing, not implemented) data non-stop for a few days, sampling frequency of 1 Hz.

 

  • Minor issue: I’m using a differential voltage card (NI 9239) for measuring 2 shunt resistors. I’m dividing the shunt voltage readings by a number and displaying them on the front panel as currents (Load Current, Power Current): these are highly fluctuating and nowhere close to what I expect. I’m not sure whether the problem is in the data logging or on the mathematical operation.

 

  • Minor issue: is there a better way of wiring up waveform graphs? I think what I did is very stupid.

I really hope I have explained things properly, many many thanks to whoever will help!

0 Kudos
Message 1 of 7
(383 Views)

Hi even,

 

to solve that Error -200279: DON'T use an additional wait time in your loop when you have set the DAQmx task to a fixed samplerate!

 

Other things:

- get rid of all those ExpressVIs (SplitSignal, MergeSignal) when handling your sample data! Use simple IndexArray functions instead!

- just read 1 sample per channel instead of "N samples" with a default "-1" for number of samples: now you will get just a 1D array of samples, with one sample per channel. No need to convert a 2D array to DDT to several DDTs to not so many DDTs to 1D arrays! Much easier!

Like this:

check.png

 

Best regards,
GerdW
CLAD expired, using 2009SP1 + LV2011SP1 + LV2017 (+LV2019 sometimes) on Win7+cRIO
Kudos are welcome Smiley Wink

Message 2 of 7
(370 Views)

Hi Gerard,

 

Thanks so much for your reply. Unfortunately I have already tried the following:

 

to solve that Error -200279: DON'T use an additional wait time in your loop when you have set the DAQmx task to a fixed samplerate!

- I already have a fixed sample rate (I think)

- while loop with no wait time still flags Error -200279

 

Other things:

- get rid of all those ExpressVIs (SplitSignal, MergeSignal) when handling your sample data! Use simple IndexArray functions instead!

- Index array for splirring the gives me very random numbers, any idea why? I will try again though.

 

- just read 1 sample per channel instead of "N samples" with a default "-1" for number of samples: now you will get just a 1D array of samples, with one sample per channel. No need to convert a 2D array to DDT to several DDTs to not so many DDTs to 1D arrays! Much easier!

- Cool! I will try that.

 

Thank you!

0 Kudos
Message 3 of 7
(365 Views)

Hi even,

 

your "Global channel" consists of 3 entries: Power, Load, and Cell5:1. I guess these are 7 DAQmx channels - but you should know that for sure from your global definition. That's why I index upto 7 values from the 1D array.

 

Btw. your first entry is "Power", but you wired that value to the Load indicator. The 2nd "Load" value is wired to the Power indicator - do you know why you did that?

Best regards,
GerdW
CLAD expired, using 2009SP1 + LV2011SP1 + LV2017 (+LV2019 sometimes) on Win7+cRIO
Kudos are welcome Smiley Wink

Message 4 of 7
(354 Views)

Please read the Data Sheet of your 9239

The smallest possible sampling rate is about 1.62 kHz. Even if you request 1 Hz aquisition rate, daqmx will ignore this request and coerce this to a valid valie.

 

Regards, Jens

Kudos are welcome...
Message 5 of 7
(353 Views)
Solution
Accepted by topic author even91

Hi even,

 

Jens is right! I didn't notice that special DAQ device.

 

So set a sample rate of 2.5kHz, read 2500 samples per channel and average each channel to get again 1S/s in the loop.

You might also set 2.5kHz samplerate and read 500 samples to get a new set of data each 0.2s…

Best regards,
GerdW
CLAD expired, using 2009SP1 + LV2011SP1 + LV2017 (+LV2019 sometimes) on Win7+cRIO
Kudos are welcome Smiley Wink

Message 6 of 7
(351 Views)

Thank you so much guys!!

0 Kudos
Message 7 of 7
(305 Views)