LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error -200220 occurred at DAQmx Create Channel (AI-Voltage-Basic).vi:1780002

Hi. I am testing my NI MyDAQ for the EMG monitor I downloaded from this community. And the error stated above occurs. What is the solution in this problem? Thank you.

0 Kudos
Message 1 of 10
(2,217 Views)

The Device Identifier is invalid.  If we saw the code (attach a VI, not a picture, please), we might be able to tell you how to fix this ...

 

Bob Schor

0 Kudos
Message 2 of 10
(2,184 Views)

Hello. This is the VI that I have downloaded in this site, also there are no .png images attached on the zip file. Can you also help me with that? Thank you

0 Kudos
Message 3 of 10
(2,166 Views)

Hi nerudorin,

 

there is no VI, no PNG and no ZIP (and not even a link)!

Best regards,
GerdW

using LV2011SP1 + LV2017 (+LV2020 sometimes) on Win10+cRIO
0 Kudos
Message 4 of 10
(2,164 Views)

Hi. I'm sorry, https://decibel.ni.com/content/docs/DOC-25987#comment-51398 this is the link for the myEMG monitor I am trying to modify. I uploaded the VI but seems it wasn't. Try to go on the link so you can try the emg monitor and can identify the problem. Thanks, Godbless.

0 Kudos
Message 5 of 10
(2,159 Views)

Hi nerudorin,

 

unfortunately I don't have the needed BiomedicalToolkit installed, so I cannot check the settings in all those ExpressVIs and missing functions…

 

From plot names I guess the original author had a device named "myDAQ1" - do you use the same?

Best regards,
GerdW

using LV2011SP1 + LV2017 (+LV2020 sometimes) on Win10+cRIO
0 Kudos
Message 6 of 10
(2,156 Views)

I suspect that GerdW (and I) has identified the problem you are having.  You use an Express VI to take the data from your MyDAQ.  It wants to "talk to" a specific named device, and if it doesn't "see" a device by that name, it will throw the Error you encountered.

 

  • Is your MyDAQ plugged into your PC via its USB cable?
  • If you open MAX, can MAX "see" your MyDAQ?
  • Note the name that MAX gives to your MyDAQ.  You need to use the same name to connect to that MyDAQ with your ExpressVI.  Do you know how to check and make sure that is the case?  Alternatively, you can use MAX to reassign the name it gives your connected MyDAQ so that it matches the name the Express VI wants to see.

Bob Schor

0 Kudos
Message 7 of 10
(2,146 Views)

Thank you for all your help, I'll try to do your suggested solutions. I'll keep you posted.

0 Kudos
Message 8 of 10
(2,128 Views)

Error -200220 occurred at DAQmx Create Channel (AI-Voltage-Basic).vi:1780002

0 Kudos
Message 9 of 10
(1,757 Views)

@SGT101 wrote:

Error -200220 occurred at DAQmx Create Channel (AI-Voltage-Basic).vi:1780002


Okay.  So you have the same error message as described in this message thread you posted into.  Do any of the previous messages help?  If not, then give some useful information with your message.

0 Kudos
Message 10 of 10
(1,752 Views)