LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error -200124 occurred at DAQmx Control Task.vi:3900002

Hi,

i have a problem with simultaneous read and write digital input/output witch NI 9401 Module. 

The following error is occuring:

 

Error -200125 occurred at DAQmx Control Task.vi:3900003

 

Possible reason(s):

 

Lines 4 through 7 of this port are configured for output. Cannot configure these lines for input at this time.

Device: cDAQ1Mod1
Digital Port: 0

Task Name: IGN_READ

 

On this forum and in Labview Help i didn't find another similar problem or example able to help me.

You can find the attachment to view the vi file.

 

Thanks in advance

 

0 Kudos
Message 1 of 7
(133 Views)

Hi dzanella,

 


@dzanella wrote:

i have a problem with simultaneous read and write digital input/output witch NI 9401 Module. 

The following error is occuring:

 

Error -200125 occurred at DAQmx Control Task.vi:3900003

 

Possible reason(s):

 

Lines 4 through 7 of this port are configured for output. Cannot configure these lines for input at this time.

Device: cDAQ1Mod1
Digital Port: 0

Task Name: IGN_READ


The error description is quite clear: you cannot read from DO channels…

 


@dzanella wrote:

You can find the attachment to view the vi file.


No, not yet…

Best regards,
GerdW


using LV2020 on Win8.1+cRIO
0 Kudos
Message 2 of 7
(123 Views)

thanks for your respond, but even if i change to digital input the same error occur.

Now would be there the attachment

 

0 Kudos
Message 3 of 7
(93 Views)

Hi dzanella,

 

did you read the datasheet of the NI9401 (carefully)?

It only allows to set input/output in 2 groups of 4 channels per group! Right on the first page it says:

The eight DIO channels are grouped in two ports that you can configure independently for input or output.

 

You are trying to use

  • channels 0:2 as output
  • channels 3:4 as output
  • channels 5:6 as input, but configured them as output…

So there are two failures:

  1. defining channels as output, but trying to read from them!
  2. defining channels 3+4 as output, but trying to configure channels 5+6 as input: this will not work because you try to use different settings (in/out) within the same port of channels 4:7!

More problems:

  • Why are you creating channels using DAQmxCreateChannels, but then not using that task reference? Instead you use tasks defined in MAX, which are not available to us…
  • Why do you use "one channel for all lines" setting, when you use boolean arrays later on to set your output channels?
Best regards,
GerdW


using LV2020 on Win8.1+cRIO
0 Kudos
Message 4 of 7
(86 Views)

Sorry for the late response, i resolve the problem about the channels.

I use "one channels for al the lines" because i saw it in some example and in that way the program works, then I don't undestand what you mean about using task reference in my case

0 Kudos
Message 5 of 7
(46 Views)

Hi dzanella,

 


@dzanella wrote:

I don't undestand what you mean about using task reference in my case


This:

We don't know these DAQmx task references…

 


@dzanella wrote:

Sorry for the late response, i resolve the problem about the channels.


How did you do that? This forum works best, when you provide the solution to your problem…

Best regards,
GerdW


using LV2020 on Win8.1+cRIO
0 Kudos
Message 6 of 7
(42 Views)

In IGN, FlameDet and IGN_READ tasks, i've just define the pins i use as input or output. Nothing else. Again, in that way the program works but i put this tasks when channles problem persisted so i don't know if i do in another way the program would work anyway    

0 Kudos
Message 7 of 7
(29 Views)