LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error 15 with CLFN in nisyscfg.lvlib:Set System Image

Solved!
Go to solution

Recently upgraded to LV 2012 and code that worked for imaging cRIOs in LV 2011 had to be replaced with the new and improved nisyscfg.lvlib VIs: Set System Image, Get System Image, etc,...

 

I'm receiving the following error message when my installed executable attempts to image a cRIO: 'Error 15 occurred at Call Library Function Node in nisyscfg.lvlib: Set System Image (Folder).vi:1->nisyscfg.lvlib: Set System Image (File).vi:1->GetSetSystemImage.vi'. The possible reason(s) displays: 'LabVIEW: Resource not found.'

 

What installation packages/products are required for the system configuration VIs? I'm including NISysCfg_Runtime and NISysAPI_Framework.

 

Thanks for your time.  

 

0 Kudos
Message 1 of 3
(2,504 Views)

I think I've solved part of the problem. Now I'm getting 'Error -2147220364 occurred at nisyscfg.lvlib: Set System Image (Folder).vi:1' with possible reason(s): 'NI System Configuration: (Hex 0x80040474) Command is not supported by given protocol.'

0 Kudos
Message 2 of 3
(2,490 Views)
Solution
Accepted by topic author JonN

Problem solved! The correct installation packages are: NISysAPI_Framework, NISysCfg_Runtime, mDNS_Responder, NI_Curl, NI_SSL_Support, NI_TraceEngine, NI_RPC, and the mxRmCfg.dll.

0 Kudos
Message 3 of 3
(2,447 Views)