LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error 15 After removing old DAQmx Base drivers

Hello,

 

I'm using LabVIEW 8.5.1 with DAQmx Base 3.1, and a PDA with an NI CF-6004 daq card. Up until recently, I was using a pre-created program to capture the analog inputs from the daq card and record them to a file to be analyzed later. Now that I have the data analysis down, I decided to create my own LabVIEW PDA program to record data and do a simple analysis of the raw data immediately. I created a test program yesterday, which was able to capture the analog inputs and display them on a waveform graph. I then noticed that my PDA was running out of space, so I went to the `Remove Programs' menu, and noticed that I had DAQmx Base 3.2, DAQmx Base 2.0, and a few other things that I no longer needed. (I found somewhere on the NI site that if using LabVIEW 8.5.1, one must use DAQmx Base 3.1, and not 3.2). After removing the excess programs, however, I tried to run the data acquisition software again. Now it does not run properly, and only gives me the error code of 15 (the source in the error is empty). I reinstalled the drivers to the PDA for DAQmx Base 3.1 from my PC, but this didn't fix the problem. This is the same program that was running fine yesterday (I also tried the old program, and a DAQmx base sample for continuous monitoring of voltage), but now it suddenly does not work. I looked up error 15, and found that it simply means that it doesn't recognize the device. What can I do to make it recognize the CF card, and get back on track monitoring voltages?

 

Thank-you very much!

0 Kudos
Message 1 of 6
(1,658 Views)

Kenton,

 

Does the device show up in your DAQmx Base Configuration Utility?  Try taking a look at this Knowledgebase Article that discusses this issue:

 

 http://digital.ni.com/public.nsf/allkb/035979F1F5D76552862570C7007937AB?OpenDocument

0 Kudos
Message 2 of 6
(1,637 Views)
Yes, when I go to Tools->NI-DAQmx Base Task Configuration Utility, I have the standard CFDAQExamples.cfg loaded, and it lists the device as: "NI 6004: `DEV 5'" (on Mobile Device)".
0 Kudos
Message 3 of 6
(1,634 Views)

After re-installing DAQmx Base, have you tried rebuilding the code for your PDA?  This might help to relink the code with the new drivers.

Also, what example are you using?  There have been some troubles with using Dynamic VIs with building applications.  The LabVIEW Application Builder will remove the front panel from a dynamic VI by default . When you include the dynamic VI, change the setting for Remove Panel to "No" under the VI Settings tab of the Application Builder. This will include the front panel data space for the dynamic VI, allowing it to be called from your top-level program.

 

0 Kudos
Message 4 of 6
(1,570 Views)
Yes, I rebuilt the applications that I had the source to. I'm using the `Cont Acq&Graph Multiple Voltages-Int Clk.vi' example, although none of the others in the `National Instruments/LabVIEW 8.5/examples/daqmxbase/PDA/Ai' work either. I'm rather new to LabVIEW - what are dynamic VI's?
0 Kudos
Message 5 of 6
(1,562 Views)

A dynamic VI is one that is loaded dynamically through the VI server (application control palette).

 

Not sure if this is how the example is set up, unfortunately I do not have DAQmx Base installed as of yet.  Will let you know after I get a chance to install it.

0 Kudos
Message 6 of 6
(1,529 Views)