LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Error 1430 when reading from sbRIO flash

Solved!
Go to solution

Hello,

 

From within a real-time vi, I need to read a file stored in the flash memory my sbRIO 9606 .  I have verified the file is there by FTPing into the sbRIO from my host machine.  But when I try to read the file, I get error 1430.  Here is the error text:

 

 Open/Create/Replace File in Read3D_LUT_v2.vi->RT_VQ_FR6_test.vi<APPEND>
 C:/LUT/3D_LUT.bin

 

The error code implies I need an absolute path, but I've given an absolute path.  I've tried changing the slashes to backslashes.  Is "C" the right root directory?   Code attached.

 

I'm new to LabView. What am I doing wrong?

 

I looked for some example code for reading from flash memory of a sbRIO but didnt' find any.  I'm using LabView 11.0.1. 

 

Thanks,

Andy

0 Kudos
Message 1 of 2
(847 Views)
Solution
Accepted by topic author afhoke
05-17-2016 08:38 PM

A fellow named Will at LabView tech support found the answer to my LabView RT issue.  Turns out the file path syntax depends on the real-time operating system (VxWorks in my case) and even on the specific blocks used to create the file path.  So I had to type /c/LUT/3D_LUT.bin as the path, and now it works.

 

Some refs in case they're useful to others:

 

http://www.ni.com/tutorial/14669/en/

http://digital.ni.com/public.nsf/allkb/0D6D5696E481E4808625749800497EA1

0 Kudos
Message 2 of 2
(812 Views)