LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error 1172

Solved!
Go to solution

I Have a very strange issue with error 1172, and not sure if this is related to .net or 32/64 bit os issue.

 

 

My program is calling a .net dll and is running perfectly well under my 32 bit laptop. When i run this under another 64 bit laptop (both under win7), i encountered error 1172.

 

I have tried to reinstall the .net framework but with no luck. My labview dev tool is 32 bit.

 

This is really killling me. Anyone hav idea whats going wrong? What else can i do?

0 Kudos
Message 1 of 7
(2,365 Views)

I would guess that at least 90% of the PCs running LabVIEW run a 64-bit OS and 32-bit LabVIEW (or at least have done this for the last 5 or so years).  You might put some probes on the Error Line and try to determine exactly where the Error occurs, then try to ascertain the inputs to the "bad" call.

 

Bob Schor  

0 Kudos
Message 2 of 7
(2,340 Views)

Do you run LabVIEW as an admin ?

Seemed to solve the problem here.

CLAMaxime -- Kudos are a great way to say thank you
0 Kudos
Message 3 of 7
(2,337 Views)

The exception message, and your post, doesn't give us much to go on without any details (like what is an EpdsHid, project attached, what your VI is doing etc.). Posting this would improve your chances of a helpful suggestion.

 

In lieu of that my best guess right now would be that a Windows driver is missing in your 64-bit environment for whatever hardware you are using.

0 Kudos
Message 4 of 7
(2,335 Views)

Thank you all for the feedbacks.

Attached is the subvi and dll that causing the error.

Also, i notice that there are many drivers missing from the target laptop, see encl screenshot, would this cause the issue?

The laptop has been downgraded from win10 to win7 due to labview version.

Download All
0 Kudos
Message 5 of 7
(2,317 Views)
Solution
Accepted by topic author sharinganezz

Looking at the .NET assembly you provided it makes a number of calls to the Win32 API; specifically hid.dll to enumerate devices. Odds are there is no driver for the device you are using and thus you are getting an exception:

 

2018-05-02 12_46_49-JetBrains dotPeek (Administrator).png

 

You most likely will need the Windows 7 driver for the device you are using. Contact the manufacturer or look online.

Message 6 of 7
(2,308 Views)

I've changed the target laptop to others (without drivers issue), and it is working now.

Thanks for the help, tyk007 🙂

0 Kudos
Message 7 of 7
(2,293 Views)