LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error -1074395989 occured at IMAQ ReadImageAndVisionInfo2

Hello,

I am trying to recreate the Golden Template Comparison VI for my own purposes, and facing an error at the very beginning of the program when appending the template file path.

My VI and the same section in the example are attached.

NIF1.pngNIF2.png

When I trace the appended path using the probe tool, I reach the correct location, the image file itself.

What may be causing this error? I don't think it matches this description on the NI Knowledge Base: https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z0000019PpzSAE

 

Thank you.

0 Kudos
Message 1 of 4
(1,380 Views)

When I've seen this issue in the past the solution has been one of the following:

 

  • There is an extra space or extra character in the file path that is throwing off the function (most common case)
  • The file path is too long (I've only ever seen this once and it was with a different VI)

I would start troubleshooting by slimming down your file path. Maybe put your image in C:\Users\Asus to begin with then after that works add \Documents and continue until you find where the issue was. You could also try simplifying your .jpg name just for troubleshooting purposes, but I would start with the troubleshooting step above so you are only changing one thing at a time.

 

Also for IMAQ and Vision Software questions, you may get more traffic on the Machine Vision section of the forums.

 

------

Aaron F.

National Instruments

 

0 Kudos
Message 2 of 4
(1,327 Views)

Hello Frankay,

 

Thank you for your reply.

 

I tried both of your suggestions but unfortunately neither shortening the path nor removing extra spaces in the file name worked. The same error still occurs in the same location.

0 Kudos
Message 3 of 4
(1,310 Views)

Hello again,

 

I figured out the problem. The image was being acquired to later use as a template in golden template comparison. I know that the template needs to be created with the Vision Template Editor with embedded information; but I was using a regular image, not one created with Vision Template Editor just to test. Trying a template image solved the problem at IMAQ ReadImageAndVisionInfo2.

 

I would have expected the Golden Template Comparison block to give an error, not IMAQ ReadImageAndVisionInfo2. 

Message 4 of 4
(1,306 Views)