LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error -1074360317 in IMAQdx Get Image vi

Highlighted

There's a very strange thing in "Init data transmission.vi".  You appear to be building a path from "IMAQ Vision Example Folder.vi" and a path called "AVIs" -- I don't understand this, but suspect it is wrong.

 

Bob Schor

0 Kudos
Message 11 of 21
(1,280 Views)
Highlighted

Hello Bob, 

 

I created the project as you mentioned. Please find it in the attachment. 

 

As far as  "Init data transmission.vi" is concerned there is no mistake in it. The video part  of It, is one of the example vi of vision.

0 Kudos
Message 12 of 21
(1,261 Views)
Highlighted

Hello gregoryj,

 

Can you explain it in little bit more details what I exactly need to do. Also I need to clarify that  I am trying to read video from avi file and not from Camera.

0 Kudos
Message 13 of 21
(1,255 Views)
Highlighted

In the project you most recently uploaded, there were no broken wires.

 

In the "Send" case you have IMAQdx Get Image, I think you either want to use the Read File or the AVI2 Read Frame under Vision Utilities >> Files. There is also a function for Image to Array so you don't have to flatten it to a string first.

Message 14 of 21
(1,224 Views)
Highlighted

By "mistake", I mean that this file is not found by the Project, hence the VI will have a Broken Arrow and not run.  This is possibly because you have specified a file that is part of your LabVIEW installation, and might not be part of everyone else's setup.

 

One way to "fix" this is to find the file, copy it into the Project folder, and then Add File and add the local copy to the Project.

 

Here's how your Project appears on my computer (I'm running LabVIEW 2015, but that should not matter):

Missing from Project.png

Bob Schor

 

0 Kudos
Message 15 of 21
(1,214 Views)
Highlighted

Hello gregoryj,

 

Yes you are right that there no broken wires since i made change in videoTx.vi (See attached image). Now If I run my code I got error message " Error -1074360317 in IMAQdx Get Image vi" . In order to remove the error I am trying to modify my code as per mentioned in the document but when I did those changes I got stuck in broken wires. (See previously attached image.)

 

I am actually trying to convert a code which reads video from webcam to read video from avi file. 

0 Kudos
Message 16 of 21
(1,204 Views)
Highlighted

Instead of "trying to convert code which reads Video from a WebCam", why don't you tell us what you really want to do?  If all you want to do is to call a VI with a File Name of an AVI file and a reference to a Display Image and have it display the Video, why not just code up such a system?  It is really very simple code (I think my student found it by looking under the Vision examples).  Don't try to copy the Example VIs that come with LabVIEW -- instead, look at them, understand them, then program your own VI using the bits and pieces that are relevant to your problem.

 

Bob Schor

0 Kudos
Message 17 of 21
(1,183 Views)
Highlighted

Did you see my suggestion when I said not to use the "Get Image" vi? You probably do not need a "session" if you don't have an actual camera to interface with.

0 Kudos
Message 18 of 21
(1,180 Views)
Highlighted

Hello gregoryj,

 

I tried as per you suggested but I receive different error messages which are related to those vis also. Now can you guide me how to convert image to array so that I can plug it in the existing main vi (see attached screen shot) I also tried image to array vi which you mentioned in your previous post but it also gives error which is related to itself.

 

Do you have USRP with you. Can you try yourself and then guide me what to do.

 

Many thanks for your support one again.

 

 

0 Kudos
Message 19 of 21
(1,141 Views)
Highlighted

Hi Joseph,

 

I keep getting an error when I try to open the AVI that the correct codec could not be found (-1074395970).  Smiley Frustrated

 

You may have better luck putting a windows media player ActiveX object, if that is an option.

0 Kudos
Message 20 of 21
(1,134 Views)