LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error -1073807339 VISA read

instrument port.pngerror message.pngthe error.pngthis is where i believe to be the problemthis is where i believe to be the problemIm currently working with a HMT330 Visala dewpoint and temperature transmitter and its currently timing out everytime i start the program. i need some of the information parsed, this model isn't currently supported by labview, however in the past we were able to get it to work. a few errors that i get is "-1073807346 VISA write" "-1073807246 propert node (arg 1) in VISA configure" and "-1073807339 VISA read" . Ive tried all the solutions online with not much success. attached is some of the scripts running if more information is needed i can provide it if need be.

0 Kudos
Message 1 of 23
(546 Views)
Arg 1 is the timeout value. Have you tried different values for "timeout (10 sec)"? Or just delete that wire and remove Timeout Value from the property node?
0 Kudos
Message 2 of 23
(530 Views)

Did you set that string constant to codes view? If not then that could explain the timeout error. As for your other error, is it possible that you have some other program open which has the port reserved?

0 Kudos
Message 3 of 23
(515 Views)

so for the arg 1 i found out that only occurs when i have it opened up in hyperterminal (simple mistake to fix), as for the other solution the byte number (45) right next to the read is where i have it held constant right now, and changing where it reads from hasnt done anything unless i have it confused with something else

0 Kudos
Message 4 of 23
(500 Views)

In that string that you're sending is the constant set to show codes? If not you are sending the wrong command string.

0 Kudos
Message 5 of 23
(494 Views)

what do you mean by that?

0 Kudos
Message 6 of 23
(490 Views)

@Jkahn wrote:

what do you mean by that?


You have a string that says "send\r\n" which is the string that you're sending. If that constant is not set to codes view then you're sending a literal "send\r\n" instead of the intended "send" with a carriage return and linefeed appended. Also, what is your termination character supposed to be?

0 Kudos
Message 7 of 23
(482 Views)

Im working with someone elses code so i wouldnt know if it is working the way that its intended how would i check that

0 Kudos
Message 8 of 23
(475 Views)

Could you copy and paste just the code that you pictured into a vi and post it? 

 

Also, check the manual for the device to verify the termination character that it uses. I'm assuming that it uses a termination character, so you should set Enable Termination to T and put a byte count greater than expected on your read.

0 Kudos
Message 9 of 23
(461 Views)

so i talked with the support help of Vaisala and i looked into it apparently the settings were turned off and im not quite sure how to turn them back on

0 Kudos
Message 10 of 23
(450 Views)