LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error 1073807202 with LabVIEW NXG 2.0 and Keithley 2400 source meter

Highlighted

Hello Rui,

 

Thank you for your patience and for providing all the information.  After looking through the information, it seems like the issue with the LabVIEW NXG gvi is that we are not able to interpret the instrument correctly, which is why we cannot even get VISA open to complete.

 

Do you have another GPIB instrument besides the Keithley 2400 that we could try to connect to (no need to even have a full API or commands)?  The main thing we want to try here is if we are able to open a VISA session successfully with any [GPIB] instrument.  If you don't have a GPIB instrument but have a serial instrument or something we could communicate with over VISA, that would be worth trying as well.

 

If you have another computer, could you try and see if you get the same behavior on that computer with the same software stack installed (most importantly LabVIEW NXG, VISA, and the Keithley GPIB 488.2 driver)?

 

Look forward to your update!

Clemens | Technical Support Engineer | National Instruments
0 Kudos
Message 11 of 16
(233 Views)
Highlighted

Hi, Clemens,

 

Sorry to reply to you so late.

 

I changed the computer (everything else same) but the same error still happened.

 

I was able to find another two GPIB to USB cable. The first one was a Keithley one, KUSB-488A (older than the one I have, KUSB-488B) and a NI GPIB-USB-HS cable.

 

For the KUSB-488A cable, the driver software was the same as the one I installed for KUSB-488B, KI-488_version 3.13. Exactly the same error happened. 

 

For the NI GPIB-USB-HS cable, everything was fine. No error at all.

 

I found another GPIB device but it seemed to be quite old and I couldn't communicate with it at all in NI-MAX visa test panel.

0 Kudos
Message 12 of 16
(217 Views)
Highlighted

Hello Rui,

 

Thank you for the reply.  We really appreciate you testing things out on your end and getting back to us.  Based on the results of your tests, I have discussed with our R&D team and this seems like unexpected behavior.  So, I have filed a bug report to the R&D team.  Since we cannot give a fix date, are you okay with the solution of using either LabVIEW 2017 with the Keithley cable or LabVIEW 2017/LabVIEW NXG with the NI GPIB-USB-HS cable?

 

Best regards,

 

Clemens | Technical Support Engineer | National Instruments
0 Kudos
Message 13 of 16
(196 Views)
Highlighted

There is a new driver released for the KUSB-488B which is both 32-bit and 64-bit NI-VISA compatible.

Suggest you uninstall the existing driver and try the latest one to see if this helps.

https://www.tek.com/accessory/ki-488/3-1-3-1

 

I have also used the KUSB-488A, but this requires a different driver, so be careful which you use with which driver.

Here is the correct driver for the KUSB-488A:

https://www.tek.com/accessory/gpib488/9-2-0

 

 

0 Kudos
Message 14 of 16
(176 Views)
Highlighted

Hi,

 

Was the bug/solution to this error ever found? Because I am having the same problem.

 

Thanks

0 Kudos
Message 15 of 16
(110 Views)
Highlighted

I am successfully using the KUSB-488B with 3.13.1 driver now...

(install tip - install using the default option (don't use the "Only for Me" option).

 

 

 

0 Kudos
Message 16 of 16
(100 Views)