LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Error 1047 in LabVIEW 8.2: LabVIEW failed to send variable to the script server. Server:""

I am working with the evaluation version of labVIEW as well and I have run into another error.  I am using a MATLAB script node within a for loop and attempting to pass the for loop counter variable into the script.  When I run the code it brings up a 1047 error and says "LabVIEW failed to send variable to the script server. Server:"" ".  I looked up the error online which seems to have roots in a failed auto initialization of MATLAB.  Is there something that I can do in labVIEW to fix the problem or is it strictly a MATLAB error?  

I really appreciate your help.

0 Kudos
Message 1 of 6
(9,069 Views)
Hi Patsenat,
 
            We have a knowledgebase document on our system referring to this issue.  Try reading through this and attempting what it says.  If you still have problems, please post again.
Regards,
Jim M
Applications Engineer
National Instruments
0 Kudos
Message 2 of 6
(9,041 Views)

I'm using Labview 8.6 and Matlab 7.9 2009b on windows 7 (64bit)

 

when I tried to open the Lorenz Diff Eq.vi....it woes not work and gives the error

 

Error 1047 occurred at LabVIEW:  LabVIEW failed to send variable to the script server. Server:"" in MATLAB script node - Lorenz Diff Eq.vi

 

 

 

I think there is no inital communication for opening the MATLAB server

 

 any can help?

A.Hakim
0 Kudos
Message 3 of 6
(8,482 Views)
A.Hakim-

Were you able to follow the document linked above by Jim_M?  It seems like this is the exact issue you are seeing.  After following this Knowledge Base Article, are you still seeing the same behavior?
Regards,

Mike S
NI AE
0 Kudos
Message 4 of 6
(8,462 Views)
Yes I followed what is written there and I used the command
matlab -regserver

But I was still have problems

But thanks god I solved it by uninstalling MATLAB and reinstalling it.............all now works fine............Thanks for help
A.Hakim
0 Kudos
Message 5 of 6
(8,452 Views)

I had the exact same problem. I tried the solution #1 in this document and it worked. http://digital.ni.com/public.nsf/allkb/2B3FF46C8512C4F786256CF30071BE53

0 Kudos
Message 6 of 6
(2,702 Views)