LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error 10444 (no more memory)

Highlighted
Hello everyone

I get the error 10444 after my VI has been running for some time. It
says the error occured in AI config VI.
I understand that the buffer is full after some time but I'm just using
one point AI and so don't understand what kind of buffer LabView ist
filling up. All the parameters are set to "don't allocate memory".

Thanks for your help

Paul
0 Kudos
Message 1 of 3
(1,463 Views)
Highlighted
This can be that you have fragmentet your memory so badly that the memory
manager could not find any suitable continous block of memory for this
task.
Happends when you have little memory in the computer and/or doing a task
that alloc and dealloc memory wery often combined with some other tasks
that
also use memory in between. The cure is to minimize the memory overhead on
what
you doing and check preferenses if you have "dealloc memory as soon as
possible"
on, i have to use this in off because of fragmentation of memory in some
of my projects. Open "one point AI" and check if you can split up the vi
into one
"init" and do that one one time only, and a "read" wich you use when you
have
to get new values.


Paul Steiner wrote:
>
> Hello everyone
>
> I get the error 10444 a
fter my VI has been running for some time. It
> says the error occured in AI config VI.
> I understand that the buffer is full after some time but I'm just using
> one point AI and so don't understand what kind of buffer LabView ist
> filling up. All the parameters are set to "don't allocate memory".
>
> Thanks for your help
>
> Paul
0 Kudos
Message 2 of 3
(1,463 Views)
Highlighted
Get memory defrag utility on shareware site. I think mem-turbo or something
like that, never expired, just nagged once in a while.

"Janne G" wrote in message
news:3814615A.19EFB46A@cad.luth.se...
> This can be that you have fragmentet your memory so badly that the memory
> manager could not find any suitable continous block of memory for this
> task.
> Happends when you have little memory in the computer and/or doing a task
> that alloc and dealloc memory wery often combined with some other tasks
> that
> also use memory in between. The cure is to minimize the memory overhead on
> what
> you doing and check preferenses if you have "dealloc memory as soon as
> possible"
> on, i have to use this in off because of fragmentation of memor
y in some
> of my projects. Open "one point AI" and check if you can split up the vi
> into one
> "init" and do that one one time only, and a "read" wich you use when you
> have
> to get new values.
>
>
> Paul Steiner wrote:
> >
> > Hello everyone
> >
> > I get the error 10444 after my VI has been running for some time. It
> > says the error occured in AI config VI.
> > I understand that the buffer is full after some time but I'm just using
> > one point AI and so don't understand what kind of buffer LabView ist
> > filling up. All the parameters are set to "don't allocate memory".
> >
> > Thanks for your help
> >
> > Paul
0 Kudos
Message 3 of 3
(1,463 Views)