Showing results for 
Search instead for 
Did you mean: 

Error 1003 and Error 1000



I have created a top level VI (in a llb file) which calls all subvis (5 subvis) via VI server and display them on a subpanel control. Everything worked great in labview environment. (I had an error 1000 if i call subvis but it is not causing any problems to run the VI)


For the same, i have created an executable without any errors. But when i ran the executable, i got the following errors:

For one of the subvi: I got error 1000 (just like what i got on labview environment) and ignoring that it worked great.

For the remaining 4 subvis: I got error 1003 (which is strange) and this leads to complete disaster.


All the subvis are in same location and i have followed the same template for all (input and output parsing).


I have followed the guidelines from the forum regarding error 1003 (inclusion of all subvis in ALWAYS INCLUDED section of Source File settings) but i couldn't succeeded.


Please give me assistance on this and i was struck on this issue for two days.


NOTE: Since both the toplevel and subvis are confidential, i couldn't post on the forum. 


I am using labview 2011 and application builder is of same version. 


Thanks and regards,


0 Kudos
Message 1 of 7

Without a diagram it is hard to give you advice.

Can you remove all the confidential parts and publish a clean version?


This may be also a way find out what's going on yourself.



7.1 -- 2013
0 Kudos
Message 2 of 7

Dear Gabi,


Thanks for your immediate reply. I will discuss with my team and let you regarding posting of my VI.


Also is it possible to get VI server properties of a VI which are called by VI server?


I will be grateful if post reply for the above question.


Thanks and regards,

Sriram N

0 Kudos
Message 3 of 7

Sorry double 

7.1 -- 2013
0 Kudos
Message 4 of 7

Dear Gabi,



have attached a zipped folder contains a project that calls (top-level) and AnalogChannelRead (subvi).


VI_Ref_Daqmx opens reference of AnalogChannelRead, parses input to it thereby measuring analog voltage.  This properly works in labview environment but it failed in exe mode.  If DAQmx functions were disabled, it works well in both IDE as well as in exe mode.


I presume that on exe mode when vi is called via vi server reference, somehow exe couldn’t locate dependencies (daqmx vi package). This is not the case in IDE environment.


Please give me assistance on this.


NOTE: I have also included AnalogChanRead in ALWAYS INCLUDED setting of Project. 



0 Kudos
Message 5 of 7

Hi Sriram


This is first time that I myself saw Asynchronous Calls, which were introduced in LV 2011 only, in action. I usullay do it the old way. But there are some basic considerations that may help you. 

It seems that cannot run the VI Synchronously ( from the Method "RUN" ) and later run it Asynchrounsly as well.

Make up your mind.


Do not create a reference inside the loop. Even more if do not close it.


Does the subprogram really has to be placed somewhere at an absolute path? Try the relative way.


Hope it helps.



7.1 -- 2013
0 Kudos
Message 6 of 7

Dear Gabi,


I have found the solution for this. I have placed the subvi in a false state of a case structure which means when i run the vi that subvi is compiled but not ran.

In labview environment the subvis is compiled and run at the same time but in an exe mode somehow exe couldn't find dependencies.


When I did the above process, exe finds dependencies and sucessfully it runs. 


I couldn't attach the vi since i have deleted from my computer.





0 Kudos
Message 7 of 7