LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

EnableAutoScales=True

On the subject of EnableAutoScales=False in an *.ini file it does seem to work as indicated, preventing scale resizing.
 
How about EnableAutoScales=True?
 
I cannot re-enable autoscaling in my vi with this ini statement. In fact, if I drop a new chart/graph onto the vi it also will not respond to right mouse clicks to autoscale.
 
So my question is, having once used the ini file statement EnableAutoScales=False, how can I switch back to the default case? Using EnableAutoScales=True does not seem to work.
 
jj
0 Kudos
Message 1 of 9
(1,134 Views)
Did you restart LabVIEW after the change? You have to do this for the changes to take effect. And Labview will save it's settings when you close it down. So you have to close labview, change the file and store it, then restart LabVIEW.


Btw I don't think this ini file key is supported by NI, so who know what it does or should do. Not sure though.


Regards,


Wiebe.
0 Kudos
Message 2 of 9
(1,123 Views)

I should have been a slight more descriptive.

1) using LV 8.20

2) it does work, can't get it to un-work, i.e. changing ini value to false works, changing back to true doesn't undo the first false

3) restarted and rebooted a hundred times since I first tried this in late Winter

 

Interestingly, with frustration, if you drop a new chart/graph onto the same vi it also is rendered unable to take right clicks during runtime.... it's as if the whole project has inherited this behaviour and cannot undo it once set.

 

0 Kudos
Message 3 of 9
(1,120 Views)
Did you try to remove the entire key? Perhaps LV checks if it's there, and disregards it's value. It's a long shot...


Regards,


Wiebe.
0 Kudos
Message 4 of 9
(1,106 Views)
You may want to try to rename the labview.ini file all together.  LabVIEW will rebuild the ini file and you can see if that takes effect.  I say rename so that if you want to go back to what you had you can always delete the new ini file and return to the old one.  Tell us if that has any effect.
Brian K.
0 Kudos
Message 5 of 9
(1,094 Views)

I tried the renaming to no avail.

 

0 Kudos
Message 6 of 9
(1,088 Views)
Have you tried repairing LabVIEW?  I tried adding and removing the key and it seemed to work fine for me.  Can anyone else confirm this sort of behavior?
Brian K.
0 Kudos
Message 7 of 9
(1,059 Views)
I have resolved this issue with the help desk. A guy named Craig showed me the follies of my ways... nothing wrong with LV on this point, it was the programmer, me!
0 Kudos
Message 8 of 9
(1,050 Views)


@jeffdf wrote:
On the subject of EnableAutoScales=False in an *.ini file it does seem to work as indicated, preventing scale resizing.
 
How about EnableAutoScales=True?
 
I cannot re-enable autoscaling in my vi with this ini statement. In fact, if I drop a new chart/graph onto the vi it also will not respond to right mouse clicks to autoscale.
 
So my question is, having once used the ini file statement EnableAutoScales=False, how can I switch back to the default case? Using EnableAutoScales=True does not seem to work.


This key used to be the only way to influence the behaviour of graphs when graph scales did resize back in version 6.1 or so. When multiscales got added this was also fixed by having the Auto Scale of a graph being an individual setting of each graph. I thought this key did nothing in newer LabVIEW versions but apparently it is used for the selection of the default mode when a graph is created. Nothing prevents you to go into a graph and disable or enable it on an per graph base in the pop-up menu.

Rolf Kalbermatter

Message Edited by rolfk on 07-18-2007 07:19 AM

Rolf Kalbermatter
Averna BV
LabVIEW ArchitectLabVIEW ChampionLabVIEW Instructor
0 Kudos
Message 9 of 9
(1,040 Views)