LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Edit>> Disable Panel Grid Alignment does not affect the Positioning of Front Panel Labels

In LabVIEW 2010, when I choose Edit>> Disable Panel Grid Alignment the positioning of Front Panel objects gets much finer so that I can make small adjustments. Put it does not seem to affect the positioning of front panel object labels. These object labels still move in very coarse increments and do not allow me to position them carefully.

 

How do I turn off the Grid Panel alignment for Front Panel Labels?

 

 

0 Kudos
Message 1 of 16
(6,134 Views)

You can always use the arrow keys to move selected objects with pixel resolution. Shift+Arrow will also move the selection several pixels at a time.


___________________
Try to take over the world!
0 Kudos
Message 2 of 16
(6,128 Views)

It seems like Ctrl-# shorucut doesnt work for disabling grid alignment in LabVIEW 2010.

Go to Tools >> Options >> Block Diagram >> Uncheck Block Grid Option to disable it.

 

Message 3 of 16
(5,899 Views)

The positioning of labels you encounter has not so much to do with any grid, but with the fact that for labels, LabVIEW attempts to snap them to one of the control corners if you get close enough to the owning control. Outside of a certain range of the owning control you should be able to place them easily on any pixel. The snap behaviour of owned objects is not configured through the panel grid option. I'm not aware of an option to disable this behaviour, but usually find it rather handy instead of annoying. If it happens to not be exactly as desired, I adjust with the label selected and using the cursor keys.

Rolf Kalbermatter
Averna BV
0 Kudos
Message 4 of 16
(5,897 Views)

@puneet K wrote:

It seems like Ctrl-# shorucut doesnt work for disabling grid alignment in LabVIEW 2010.

Go to Tools >> Options >> Block Diagram >> Uncheck Block Grid Option to disable it.

 


It works fine here both in 2009 and 2011. Make sure you use Ctrl+Shift+3. If that doesn't work, make sure you don't have a French local. My understanding was that LV uses another key in that case because that's already used for one of the accents. Of course, it's possible the same applies in other languages.


___________________
Try to take over the world!
0 Kudos
Message 5 of 16
(5,889 Views)

I have tried on LabVIEW 2011 as well & on other development PC as well but it didnt worked. Tomorrow I will try Ctrl + Shift + 3 , let you know.

 

0 Kudos
Message 6 of 16
(5,882 Views)

I have tried Ctrl +Shift +3, didnt work. Check the Keyboard Input Language, which is set to United Kingdom (English). 

Still Ctrl-# doesnt work on LabVIEW 2010/2011.

0 Kudos
Message 7 of 16
(5,875 Views)

Hi Puneet,

 

If you go to Tools>>Options>>Menu Shortcuts and look for Enable Panel Grid Alignment, what does it say for the menu shortcut?

 

I just tested this and by default Ctrl+# does disable the Panel Grid Alignment in both LabVIEW 2010 and 2011.

 

Regards,

0 Kudos
Message 8 of 16
(5,862 Views)

Hi Jeff,

 

Its Ctrl+# as shown in screenshot.

 

ScreenShot.png

0 Kudos
Message 9 of 16
(5,860 Views)

Hi Puneet,

 

If you change the shortcut to something different and use that, does it work?

0 Kudos
Message 10 of 16
(5,857 Views)