Showing results for 
Search instead for 
Did you mean: 

ERROR: TDS Exception in Initialize: Tds Error: TdsErrNotTdsFile(-2503):



I´m using Labview 2010 for logging some CAN and GPIB data.

By testing and logging for view minutes everything works fine.

By logging overnight and creating a 180 MB TDMS file (CAN Msg every 100 msec, GPIB every 10 sec)

I can´t open the file anymore and find a file with the following content:

ERROR: TDS Exception in Initialize: Tds Error: TdsErrNotTdsFile(-2503):


Where could I find some informations about this error?


Message 1 of 10

Firstly, maybe you can try to delete the .tdms_index file and see whether it can work or not.


Secondly, there's a latest TDMS component on which maybe you can try with:



0 Kudos
Message 2 of 10


I have got the same problem as you. Did you ever find a solution in the meantime?



0 Kudos
Message 3 of 10

Well, it's a little bit complicated. The error code -2503 is always happened when the TDMS file is corrupted.  I have the below 2 questions:

1) Do you have this error returned for each of your TDMS file? Or do you have an code to generate such file?

2) Is that convenient for you to post your file (if the main file is too large, maybe the .tdms_index file is also OK), and we can do more investigation.


Yongqing Ye


0 Kudos
Message 4 of 10



I've got the same mistake, too. Because last posting is month ago: Do you have a solution already?


What I found out by using an Hex-Editor to compare a working tdms-index file with a corrupted one is, that at the end of the corrupted tdms-index-file the channel names have not been written. I'm not used in working with Hex-Editors but I tried to copy the missing part. That didn't work. As I told before, I am not in with Hex-Editors. For me it seems like the file hasn't been closed correctly. I generate those files by code with LabView 2010. Short measurements are ok, only the long ones but here all (mine are about 150 MB) are corrupt.

I attached one bad and a good one for you. Hope that will help.





0 Kudos
Message 5 of 10

Me again,


excuse. The problem seems to be solved in LabView 2011. I can open the files in Diadem 2011, too. There's a lot of cross posting. I didn't realize that immediately.






0 Kudos
Message 6 of 10



I have the same problem using LabVIEW 2014.

Some of the TDMS files gives error:

USI encountered an exception:

TDS Exception in Initialize: Tds Error> TdsErrNotTdsFile(-2503):

and after that

(208): Error while loading model <filename readonly:'yes'> filename path </filename> (TDMS), code: 80


The logfile contains the following;

***************** New logfile section *******************
ToRootData.cpp(212): TDMS: ERROR: TDS Exception in Initialize: Tds Error: TdsErrNotTdsFile(-2503):


Did you solved the error?




Message 7 of 10


I have the same problem using LabVIEW 2016.

Did you solved the error?




0 Kudos
Message 8 of 10

Hi HuiZhou,

not really, just saved data more frequently. After some files just put it together at once.


0 Kudos
Message 9 of 10

Please excuse this cross-board reply, but I thought I'd add my experience, from the LabWindows (CVI) side.


I'm seeing this issue too with my CVI application only occasionally.  The error returned by the function TDMS_OpenFileEx is:

Error: -6610
Description: The file is not a valid TDMS file.  

The TDMS file that was created has size, it's not empty.  When I try to import into Excel with the importer, I get the error codes posted above.

0 Kudos
Message 10 of 10