Showing results for 
Search instead for 
Did you mean: 

ERROR 1073807339

Go to solution

check if your charachter termination is correct

Certified TestStand Architect
Certified LabVIEW Architect
National Instruments France

0 Kudos
Message 11 of 22

Hi, thank you for your answer. 


I checked the charachtere termination. it's written in page 70 in the manual.


I also cheked with a feed line and a carriage return but without success 😞


any other suggestion? this intrument is driving me crazy :'(

0 Kudos
Message 12 of 22

Get a special serial adapter that splits the signal into two.  Feed the extra port into anothe serial port on your PC.  Open up a program that just reads that port and logs what comes in.


Run the manufacturer's program and log the data it sends.

Run your VI and log what it sends.


See what the difference is.


(There should also be some software that can do this internally on the PC without needing the hardware.  I just don't remember which software that is out there that can do this. 

0 Kudos
Message 13 of 22

Deleted response.

Now Using LabVIEW 2019SP1 and TestStand 2019
0 Kudos
Message 14 of 22

@RavensFan I will try this solution and keep you updated

0 Kudos
Message 15 of 22

So I used the program Serial Port Monitor to see the instructions. (Because as I said it before the connexion is working with it own program but not working with labview) what the program is sending is this code while connecting to the com11.jpg 


and I am sending the same code via NI-MAX but I am still getting the timeout error 



 Any Idea please ??  all the setting are right :S I just dont understand

0 Kudos
Message 16 of 22

I can observe that you add the Termination Character in your command.

Can you take a look at the configuration Tab and I/O Settings to see if it not already activated.

Certified TestStand Architect
Certified LabVIEW Architect
National Instruments France

0 Kudos
Message 17 of 22

It sure looks like it is sending the same command.

I can't tell from the screen shot, but you said you looked at it, so I'm going to asssume you have the baud rate, parity, stop bits all matching.

You are using the same com port, I'm going to assume you are using the same cable, so I doubt you have an issue with the wrong cable.


My last thought is that it is using some sort of flow control, possibly hardware.  That the manufacturer's program sets the RTS or DTR lines, but the LabVIEW program or VISA test panel is not, so the device is not seeing the signal saying it is okay to send data.


Using a device such as this can tell you if any of the other hardware lines on the serial port are being used.

0 Kudos
Message 18 of 22

Paolo, wouldn't that extra termination character show up in his port monitor? From what I can see, the written data matches up with the other program.


marwah, can you share a screenshot of both the configuration of your working application and MAX?


--------,       Unofficial Forum Rules and Guidelines                                           ,--------

          '---   >The shortest distance between two nodes is a straight wire>   ---'

0 Kudos
Message 19 of 22

Good morning, 

Yes I can; this is the confirguration of the program and my windows. the program doesn't show the setting of the port even if you go settings or file... 




and these are the settings of my NI-MAX connexion 



I also tried to change the time out till 5000ms but still the same error.

You have to know that I am using a converter usb\serial and that when I am using a direct USB connection I am not getting errors but always getting \01' as an answer for any request sent.

I looked for the meaning of that \01' in the manual but it doesn't even exist.

(if you are wondering why am I using a converter if I have a direct USB connection.. My manager want to use a serial connection :S)

You will also find attached the manual of this instrument.

0 Kudos
Message 20 of 22