LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Dragging typedef'ed element overs string element resets the font

Solved!
Go to solution

Dear all!

 

I have just noticed that dragging a typedef'ed element across a string element resets the font for the string element, which cannot be reverted.

 

Steps to reproduce (LabVIEW 16, 32 bit):

 

  • Create a new VI
  • Create a string element and set some custom font (more flags means more fun)
  • Create another element, right click it and create a type definition
  • Select the second element and slowly drag it across the string element
  • Observe what happens to the font

 

I don't want this to happen. Is there some configuration that I set erroneusly?

 

LLindenbauer_0-1614706135865.png

 

LLindenbauer_1-1614706236171.png

 

Message 1 of 6
(157 Views)

Interesting.  I just tried that out in LabVIEW 2020 and it did the same thing.  Seems like a bug.

I don't think I've read that one before.  Kind of surprised someone hadn't seen it before now.

Message 2 of 6
(149 Views)
Solution
Accepted by LLindenbauer

It probably relates to the fact that, by default, LV 2016 and newer have "live update" which tries to update everything in real time as you drag stuff around.  I wonder if that will still happen if you disable that option?  I forget what that option actually is.

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
Message 3 of 6
(119 Views)

@billko wrote:

It probably relates to the fact that, by default, LV 2016 and newer have "live update" which tries to update everything in real time as you drag stuff around.


That would seem to make sense, as this doesn't happen in 2015.

It looks like the typedef bit is relevant because when it's a typedef, dragging it adds the name of the typedef to the string, like it does with VIs.

 

In 2015, the format isn't reset immediately when dropping in the string. The name of the typedef is in the default format. The rest of the string keeps its format, but if I undo something, it also returns to the default format.


___________________
Try to take over the world!
Message 4 of 6
(83 Views)

I have tried pressing "x" while dragging, as per https://forums.ni.com/t5/LabVIEW/Labview-2016-new-improvments-to-selecting-moving-and-resizing/m-p/3...

 

This prevents the font change. I also tried the "LiveDrag=False" setting and that solved it too.

 

Thank You!

Message 5 of 6
(77 Views)

If I may add: Disabling Live Drag greatly improved the performance and user experience when using the block diagram editor. I wish I would have tried this sooner.

Message 6 of 6
(59 Views)