Showing results for 
Search instead for 
Did you mean: 

Distibution Build Error (Ver 8.5)

Go to solution

Hello - I am fairly familiar with Labview Project and the source distribution but this one has me stumped. When I try to build, I get the following error message and can't undersatnd the duplicity or path error. The daqmx.rc is where it is supposed to be and it is not read only. I have built many applications and source distributions with DaqMX as well. Here is the error message. Any takers?


Possible Reasons:

Error copying files.

Source: ..\..\Program Files\National Instruments\LabVIEW 8.5\resource\objmgr\daqmx.rc

Destination: F:\APPS\National Instruments\LabView Apps\builds\A6_A7\A6_A7 Source Distribution\daqmx.rc

Librarian Path



Visit the Request Support page at to learn more about resolving this problem. Use the following information as a reference:

Error 1 occurred at -> -> -> -> -> -> ->

Possible reason(s):

LabVIEW: An input parameter is invalid. For example if the input is a path, the path might contain a character not allowed by the OS such as ? or @.


NI-488: Command requires GPIB Controller to be Controller-In-Charge.

0 Kudos
Message 1 of 14
Perhaps this Knowledge Base might help -
George M
National Instruments
0 Kudos
Message 2 of 14


There is no official documentation on this error but there have been a few other customers on the discussion forums who have had this error. If the preceding document helps, please reply and post the details of your solution.

If the previous document does not help, please refer to these other threads:


Please post the solution if any of these threads help.

Vince M
Applications Engineer
0 Kudos
Message 3 of 14

Sorry George M. - either my company's firewall or your address is giving me the following error.


Network Error (dns_unresolved_hostname)

Your requested host "" could not be resolved by DNS.

For assistance, contact your network support team.

Message Edited by j.masse on 01-19-2009 03:29 AM
0 Kudos
Message 4 of 14

Vince M. - None of the links were of any benefit. Can you answer a couple more questions?

1. What is daqmx.rc?

2. Can it be found in any VI? (Maybe there is a bad link? I replaced every DaqMX VI with new ones but that did not help. I have had instances of corrupt VIs.)

I have attached an image that may provide additional help. When I 'generate preview' in the build environment, the problem build seems to want to put 2 copies of 'daqmx.rc' in the support files but in a successful build there is 1 copy of 'daqmx.rc' in the destination directory. Why the difference?

Message Edited by j.masse on 01-19-2009 04:48 AM
0 Kudos
Message 5 of 14
I apologize I copied an incorrect link. Here is the corrected link -
George M
National Instruments
Message 6 of 14

I don't know why there are two copies of the daqmx.rc but the KnowledgeBase attached above should answer the other questions that you have.


Please try what is recommended in that article and post here to verify whether or not that worked.

Vince M
Applications Engineer
0 Kudos
Message 7 of 14
Accepted by topic author j.masse
Thanks for the posts! The knowledgebase article helped. My source distribution now works. It may be related to the fact that I am using DAQmx and I am also programatically registering a tree event. (?) Anyway, thanks for sticking in with me until this got solved.
0 Kudos
Message 8 of 14
Please don't mark your own reply as the solution to the problem.  Mark which person's reply helped you the most.
Message 9 of 14



Here is a program that solves the problem automatically.

Just do these simple steps:


1. Remove the VI's from your project

2. Move them to a new location with the VI below

3. Add the VI's back to your project

4. Voilá!


- Tomi

0 Kudos
Message 10 of 14