Showing results for 
Search instead for 
Did you mean: 

Disabling TCP delay (Nagle algorithm, tcp_no_delay) globaly on RT Linux

I am sending small messages ( a few strings) frequently ( <100ms) to RESTfull API. I found and tested that and see much difference using the provided example. The problem I have got is that I am using RESTfull API which is build on top of HTTP and I don't have access to raw TCP port.


Does anybody knows how to turn off Nagle algorithm on  RT Linux (cRIO 9035) globaly?


I have also tried tcp_no_latency  flag: but it is being overwritten on the system startup. Has anybody had similar problem?

0 Kudos
Message 1 of 1