LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Disable keyboard search in Multicolumn Listbox

Solved!
Go to solution

Hi everyone,

 

I have a multicolumn listbox that looks like this:

grafik.png

 

Also I have an event structure that is supposed to handle CTRL+C.

Unfortunately everytime i press C or CTRL+C the active line in the listbox jumps to the next item starting with "c".

How can I disable this "search" feature inside the listbox?

 

Thx in advance

0 Kudos
Message 1 of 4
(529 Views)

Hello Tesla,

I couldn't find a way to disable listbox shortcuts, but you can go to Tools>Options>Menu Shortcuts and change the "copy" shortcut inside LabVIEW (for example to Ctrl+Alt+C).

This way you won't trigger the "search" function. It's not perfect, but less annoying Smiley Happy

0 Kudos
Message 2 of 4
(509 Views)
Solution
Accepted by topic author Tesla1977

Catch the Key Down? event (not the Key Down event). If it's an ascii character, set discard? to true. Else, set it to false. This will effectively disable that functionality.

Message 3 of 4
(495 Views)

Yes, that did it, thank you.

I simply discarded the scancodes for x, c, and v in the Key-Down?-Event.

And in the Key-Up-Event I can still handle Ctrl-C.

0 Kudos
Message 4 of 4
(469 Views)