LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Digital in signal is unstable PCI-6509, please help

Hello all,
 
i'm trying to do the most simple vi that you probably done before.
i want to read one port  (digital In PCI 6509).
I already build a new Task in  MAX and when i test the port i always get unstable signal.
 
i use the pci-6509 96DIO with CB-100 I/O with two CB-50 connector blocks and cables.
i configure port 2 to be digital input (pins numbers in the  CB-50  are : 15,13,11,9,7,5,3,1 )
i want to read the signal for each line in this port.
each line connected to relay (and the relay connected to 24VDC sensor)
so i have 8 relays connected to this port.
and when i read the port using the MAX i get garbage...
 
Please help
 
thanks in advanced
Mor
 
 
0 Kudos
Message 1 of 4
(1,999 Views)
Hello Mor,

It sounds like you are trying to connect 24 V sensors to your PCI-6509. The 6509 only supports TTL logic which is a max of 5.5 V according to the Digital I/O Help file.  A voltage above 5 V with respect to GND could potentially damage your board. 

Try using the Measurement and Automation Explorer's device test panels and a 5V signal to verify you have your hardware configured correctly.

If you are still having trouble post again and we'll be glad to help you out.

Regards,
Micaela N
National Instruments
0 Kudos
Message 2 of 4
(1,975 Views)

Dear Micaela ,

Thanks fopr your reply.

i found that when i put resistor between the input line and ground (pin 50) the signal is stable.

so, i connect for each line resistor and everything is perfect now.

i do not connect the relay 24V directly to the pci 6509.

i also talk with my local NI office and they told me that what i do (connecting the resistors) was verry good.

they also told me to look in MAX in pci6509 properties and to uncheck the Tristate which is the default for the port i configure (port2)

i didnt uncheck it, but the resistors solve the problem.

Thanks for your help.

if you can direct me to link about Tristate, what and when i need to use it, i'll appriciate that.

Thanks.

Moti Mor.

 

 

 

0 Kudos
Message 3 of 4
(1,964 Views)
Hello Moti Mor,

The tristate state is a high impedance state.  The What Is the State of the Digital I/O Channels of My Device When My Computer Powers On? explains that this state is the default state for your 6509.  The example program, DAQmx - Setting the Digital Output to Tri-State on Multifunction DAQ Boards sets a digital output line to tristate.  We also have a tutorial on our Developer Zone which explains the states of a digital line, the Digital Test - Beyond 1s and 0s.

Hopefully these references will get you going.  Good luck and post again if you have questions about the above links.

Regards,
Micaela N
National Instruments
0 Kudos
Message 4 of 4
(1,952 Views)