LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Digital Thermometer Center309

Highlighted

 

I want to use LabVIEW to monitor the temperature using Digital Thermometer Center309 (Center Co.). But I have not been able to do that.

The thermometer used is shown below.

(https://www.triotest.com.au/store/thermocouple-thermometers/990-center-309-thermometer-k-type-4-inpu...)

The USB used is RS-232.

The operation of the software(SE309) included with the thermometer has been confirmed.

I was able to confirm the USB connection with NI MAX.

I also tried to communicate with the thermometer using NI MAX's Visa Test Panel, Input/Output.

It seems that writing is working properly. However, reading does not work properly.

When I read and write VISA in LabVIEW, the operation stops at the reading.

 

How do I get the temperature from the thermometer?

Pleas teach me.

 

(I am very happy if the answer is Japanese.)

 

0 Kudos
Message 1 of 6
(78 Views)

Why do you think this device would respond to a query of *IDN?

 

Was there an error number associated with the read error?

 

Did you read the manual for this device to see what commands it does respond to?

 

Have you tried to see if it works with any software they provide?

0 Kudos
Message 2 of 6
(62 Views)

I don't know a query of *IDN, and  the proper command.

Error number is -1073807339.

I didn't find a command in the manual.

The operation of the software(SE309) provided by the Center Co. has been confirmed.

0 Kudos
Message 3 of 6
(51 Views)

That is a timeout error meaning the device didn't respond.

 

If you don't know of a query of *IDN, then why did you run that query when you were testing with MAX?

 

If you don't know what commands you should send, it sounds like you need to find the communications manual for what the commands are, or contact the manufacturer of this device and ask them!

 

Another thing you could to, since you confirmed their software works is to use a port sniffer such as Wireshark and snoop on the conversation between their software and their device.

0 Kudos
Message 4 of 6
(44 Views)

How should I handle it in case of timeout error? Or is this due to no device response?

 

The reason for executing *IDN is because it was at the top of "List of preloaded and previously sent data blocks."

 

I'm currently looking for a communication manual. If you know the communication manual about USB-RS-232, please teach me.

 

What are a port sniffer, wireshark and snoop?
I don't know that, please teach me.

0 Kudos
Message 5 of 6
(39 Views)

It is due to no device response.

 

I don't know why you would send a command just because it is there.  Actually I hate that IDN seems to be default in so many LabVIEW examples.  Actually very few devices response to that, and people get confused when it doesn't magically work for them.

 

There is no manual for USB-RS232.  That is just a serial port adapter.

 

You need the manual from the manufacturer.  It is their device and they define what the commands and responses are.

 

Wireshark

http://lmgtfy.com/?q=wireshark&s=g

 

http://lmgtfy.com/?q=wireshark&s=g

0 Kudos
Message 6 of 6
(33 Views)