LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Develop DAQmx 2009 on LV2012 computer

Hello,

I have a question regarding the development of DAQmx applications in 2009 on a development computer with LV2012 installed.

I can create applications in 2012, say for example the DAQmx read vi, and save backward to 2009 with no problem. Of course when I open it, however, it wants me to direct it to the DAQmx vis in the DAQmx llb, that typically live in vi.lib/DAQmx.

With LV2012 installed, I cannot install DAQmx 2009, and of course if I direct it to the llbs installed with 2012 they are of a newer version and therefore unusable.

Is there any solution to this problem except developing in 2012, saving backward to 2009, ensuring all vi functions are compatible, and opening it on the target computer? It would be ideal to develop with the 2009 drivers, rather than develop in 2012 and hope all of the features are compatible.

Thanks,
C

PhD ChemE, CLD, Alliance Partner : www.interfaceinnovations.org
0 Kudos
Message 1 of 5
(1,252 Views)

@ColinCR wrote:

Hello,

I have a question regarding the development of DAQmx applications in 2009 on a development computer with LV2012 installed.

I can create applications in 2012, say for example the DAQmx read vi, and save backward to 2009 with no problem. Of course when I open it, however, it wants me to direct it to the DAQmx vis in the DAQmx llb, that typically live in vi.lib/DAQmx.

With LV2012 installed, I cannot install DAQmx 2009, and of course if I direct it to the llbs installed with 2012 they are of a newer version and therefore unusable.

Is there any solution to this problem except developing in 2012, saving backward to 2009, ensuring all vi functions are compatible, and opening it on the target computer? It would be ideal to develop with the 2009 drivers, rather than develop in 2012 and hope all of the features are compatible.

Thanks,
C


The most recent NI-DAQmx drivers I installed was version 9.9

There may be newer version since then.

There is no NI-DAQmx 2009, so I don't understand what you talking about.

 

 

0 Kudos
Message 2 of 5
(1,250 Views)
  • The version of DAQmx installed with LV2012 cannot be used with LV2009
  • Versions compatible with LV2009 cannot be installed on a computer with LV2012 installed

 

Apparently the above are just facts, and if I want to develop natively I'll need to do so on another machine.

 

Cheers,
C

PhD ChemE, CLD, Alliance Partner : www.interfaceinnovations.org
0 Kudos
Message 3 of 5
(1,246 Views)

As NYC said, there is no DAQmx 2009.

 

Here is the compatibility chart between DAQmx versions and LabVIEW. Compatibility LabVIEW & DAQmx

 

Try installing DAQmx version 9.7.  If you have a newer version installed than that, then uninstall the newer version and install 9.7.  That version works with both LabVIEW 2009 and 2012.  Make sure you install DAQmx AFTER installing LabVIEW.

 

I also don't understand what you are talking about when you say it is trying to look in VI.lib.  When you open LabVIEW, it will load the appropriate DAQmx functions as long as they were properly installed into that version of LabVIEW.

0 Kudos
Message 4 of 5
(1,244 Views)

Let me rephrase: I cannot install DAQmx when installing LV2009.

 

If you fire up 2009 with a 2012 vi saved for 2009, it will prompt you to find the DAQmx vis. These typically exist in llbs in vi.lib/DAQmx. Of course if you haven't installed them, in this case in LabVIEW 2009/vi.lib, they will not be there.

 

I'll install the mutually compatible version.

 

Thanks,

C

PhD ChemE, CLD, Alliance Partner : www.interfaceinnovations.org
0 Kudos
Message 5 of 5
(1,237 Views)