Showing results for 
Search instead for 
Did you mean: 

Deployment of Shared Variable Failed

I have created an installer for my TestStand program.  It consists of many LabVIEW modules, none of which are executables.  I have deployed it to a machine with the full version of TestStand, but only a run-time LabVIEW engine (included in the installer).  NI Variable Engine has also been included, although I can't find where it actually installed.  When I run the TestStand program, I receive the following error:

Unable to located variable in the shared variable engine.  Deployment of this variable may have failed.

I see several possible issues I need help working through.

1.  Does each LabVIEW module need to be made into executable form with "Deploy All" selected for the shared variables?

2.  Why can't I find NI Variable Engine on the deployment machine even though it is included in the installer?

3.  Based on the error, it looks like it found the shared variable engine, just not the particular variable.  Is this a correct assumption?

0 Kudos
Message 1 of 2


I have restarted NI Variable Engine on deployment machine as well as the machine it is communicating with (client/server setup).  No change.  Both machines are reporting errors.  The client has not had anything changed and can't be the issue, but is reporting the error:

Error -1950679023 occurred at Shared Variable in (name-of-vi).vi

Possible causes:

LabVIEW (Hex 0x8BBB0011) The connection to the server was disconnected.

Can not find variable (name-of-variable).

The TestStand program is reporting the same error as before.  As mentioned earlier, I can confirm that NI Variable Engine is running on both machines.  (To clarify the client/server relationship.  TestStand doesn't act as the server.  There is a third machine with a server.  The client and server work together to feed information to and from TestStand.)

0 Kudos
Message 2 of 2