LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Deployment Error When Deploying Labview to Raspberry Pi through LINX

Solved!
Go to solution

I am using Raspberry Pi 3 with raspbian jessie and installed labview 2014(32bit) in my windows 7 laptop.

Everything goes smoothly as I connect to my rpi using the linx target configuration. The problem is that everytime deploy a vi (I deployed blink), i get this:

Initializing...
Calculating dependencies...
Checking items for conflicts. This operation could take a while...
Preparing items for download. This operation could take a while...
Deploying NI_PtbyPt.lvlib
Deploying LMH-LINX.lvlib
Deploying LMH-LINX.lvlib:Local IO.lvlib
Deploying LMH-LINX.lvlibSmiley Very Happyevice.lvlib
Deploying LMH-LINX.lvlib:myRIO.lvlib
Deploying LMH-LINX.lvlib:Interaction Parts Kit.lvlib
Deploying LMH-LINX.lvlib:Ultrasonic.lvlib
Deploying LMH-LINX.lvlib:TMP3x.lvlib
Deploying LMH-LINX.lvlib:TCN75A.lvlib
Deploying LMH-LINX.lvlibSmiley TonguemodTC1.lvlib
Deploying LMH-LINX.lvlibSmiley TonguemodGPS.lvlib
Deploying LMH-LINX.lvlibSmiley TonguemodMAXSONAR.lvlib
Deploying LMH-LINX.lvlibSmiley TonguemodBT2.lvlib
Deploying LMH-LINX.lvlibSmiley TonguemodGYRO.lvlib
Deploying LMH-LINX.lvlibSmiley TonguemodALS.lvlib
Deploying LMH-LINX.lvlibSmiley TonguemodACL2.lvlib
Deploying LMH-LINX.lvlibSmiley TonguemodACL.lvlib
Deploying LMH-LINX.lvlibSmiley TonguemodTMP3.lvlib
Deploying LMH-LINX.lvlibSmiley TonguemodMIC3.lvlib
Deploying LMH-LINX.lvlibSmiley TonguemodJSTK.lvlib
Deploying LMH-LINX.lvlibSmiley TonguemodCMPS.lvlib
Deploying LMH-LINX.lvlib:LTC2631.lvlib
Deploying LMH-LINX.lvlib:AD9850.lvlib
Deploying LMH-LINX.lvlib:WS2812.lvlib
Deploying LMH-LINX.lvlib:BlinkM.lvlib
Deploying LMH-LINX.lvlibSmiley FrustratedSD1306.lvlib
Deploying LMH-LINX.lvlib:HiTechnic.lvlib
Deploying LMH-LINX.lvlib:HiTechnic.lvlib:Accelerometer.lvlib
Deploying LMH-LINX.lvlibSmiley Frustratedervo.lvlib
Deploying LMH-LINX.lvlibSmiley Very HappyS1307.lvlib
Deploying LMH-LINX.lvlib:MMA8452.lvlib
Deploying LMH-LINX.lvlib:MMA8451.lvlib
Deploying LMH-LINX.lvlib:ADXL345.lvlib
Deploying LMH-LINX.lvlib:MPU60X0.lvlib
Deploying Raspberry Pi 2 B(successfully deployed target settings)
Deploying TagReturnType.ctl (1.32 K)
Deploying whitespace.ctl (1.32 K)
Deploying LMH-LINX.lvlibSmiley Very Happyevice.lvlib:TCP Config.ctl (1.58 K)
Deploying LMH-LINX.lvlibSmiley Tonguelatform.ctl (1.32 K)
Deploying Trim Whitespace.vi (3.18 K)
Deploying LMH-LINX.lvlib:Channels.ctl (4.50 K)
Deploying Search and Replace Pattern.vi (8.40 K)
Deploying Find Tag.vi (11.43 K)
Deploying LMH-LINX.lvlibSmiley Very Happyevice.lvlib:LINX VI API Version.vi (2.93 K)
Deploying Format Message String.vi (6.47 K)
Deploying NI_PtbyPt.lvlib:Update Summation.vi (7.55 K)
Deploying GetRTHostConnectedProp.vi (3.83 K)
Deploying LMH-LINX.lvlibSmiley Very Happyevice Firmware.ctl (2.51 K)
Deploying LMH-LINX.lvlibSmiley Very Happyevice.lvlib:Bit Pack.vi (5.18 K)
Deploying LMH-LINX.lvlib:Error Type.ctl (1.32 K)
Deploying VISA Configure Serial Port (Instr).vi (7.45 K)
Deploying LMH-LINX.lvlib:Interface.ctl (1.32 K)
Deploying NI_PtbyPt.lvlib:Mean PtByPt.vi (10.42 K)
Deploying LMH-LINX.lvlib:Loop Frequency.vi (4.69 K)
Deploying Check Special Tags.vi (5.77 K)
Deploying DialogTypeEnum.ctl (1.32 K)
Deploying LMH-LINX.lvlib:User Platform.ctl (1.32 K)
Deploying LMH-LINX.lvlib:Get Platform.vi (3.61 K)
Deploying LMH-LINX.lvlib:Clean Error Call Chain.vi (13.03 K)
Deploying DialogType.ctl (1.32 K)
Deploying LMH-LINX.lvlibSmiley Very Happyevice Data.ctl (2.37 K)
Deploying Error Code Database.vi (4.39 K)
Deploying General Error Handler Core CORE.vi (47.32 K)
Deploying General Error Handler.vi (10.75 K)
Deploying LMH-LINX.lvlibSmiley Very Happyevice.lvlib:Firmware Version.ctl (1.43 K)
Deploying LMH-LINX.lvlibSmiley Very Happyevice.lvlibSmiley Tongueacket Number FGV Action.ctl (1.32 K)
Deploying Error Cluster From Error Code.vi (9.29 K)
Deploying LMH-LINX.lvlibSmiley Very Happyevice.lvlib:LINX Device Config.ctl (5.16 K)
Deploying LMH-LINX.lvlibSmiley Very Happyevice.lvlibSmiley Frustratederial Set Baud.vi (6.57 K)
Deploying LMH-LINX.lvlib:LINX Ref.ctl (5.32 K)
Deploying LMH-LINX.lvlib:Local IO.lvlib:Load Device Channels.viLMH-LINX.lvlib:Local IO.lvlib:Load Device Channels.vi loaded with errors on the target and was closed.
Deployment completed with errors

 

How can I complete deployment without having any errors?

0 Kudos
Message 1 of 10
(2,537 Views)

You might also want to post this to the LabVIEW MakerHub and hopefully someone familiar with it will see.



CLA // LabVIEW 2016 // BALUG // GCentral.org // Unofficial Forum Rules and Guidelines

www.gcentral.org
0 Kudos
Message 2 of 10
(2,515 Views)

I have tried to post this to the labview makerhub forum last week but it was not posted, it needs to be accepted by the moderator before being posted. And as I have searched, its admin last visited the site a month ago. 

0 Kudos
Message 3 of 10
(2,508 Views)
Solution
Accepted by topic author 24601

I was having the same issue. The fix for me was here;

https://www.labviewmakerhub.com/forums/viewtopic.php?f=12&t=3018

Navigated to the :/srv/chroot/labview/usr/lib directory

and ran the command;

ln -s ./liblinxdevice_rpi2.so ./liblinxdevice.so

 

I also set up manually before hand as suggested further on.

Message 4 of 10
(2,485 Views)

@geovogel wrote:

I was having the same issue. The fix for me was here;

https://www.labviewmakerhub.com/forums/viewtopic.php?f=12&t=3018

Navigated to the :/srv/chroot/labview/usr/lib directory

and ran the command;

ln -s ./liblinxdevice_rpi2.so ./liblinxdevice.so

 

I also set up manually before hand as suggested further on.


Thank you! Your instructions made the steps in the labviewmakerhub forum easier. 

However, everytime I try running a VI, before I can even click anything in the VI's panel, the connection to my raspberry pi will suddenly be lost. Do you have something in mind on how to fix this?

 

My primary guess for this error's culprit is my internet connection with my rpi; it is connected to the internet through lan cable. I plugging out the cable and plugging it in again, but the problem still persist. I also tried rebooting my rpi, but the same happened.

0 Kudos
Message 5 of 10
(2,453 Views)

24601,

 

So any program that communicates with your Raspberry Pi is causing it to lose connection?

 

That sounds like an unhandled error or something else unexpected in the software. Try using highlight execution to see at what point the connection is lost.

 

VanCamp

0 Kudos
Message 6 of 10
(2,430 Views)

Yah..I am also getting the same error.

Before this "

I was having the same issue. The fix for me was here;

https://www.labviewmakerhub.com/forums/viewtopic.php?f=12&t=3018

Navigated to the :/srv/chroot/labview/usr/lib directory

and ran the command;

ln -s ./liblinxdevice_rpi2.so ./liblinxdevice.so

"

Pi was connecting. After setting up this code, it shows an error.

 

Does any one sorted out this issue?

 

0 Kudos
Message 7 of 10
(1,519 Views)

Hi Vancamp

 

Did your problem gotresolved?

 

Pls let me know

0 Kudos
Message 8 of 10
(1,505 Views)


hi every one


go to this directory 
"    /svr/chroot/labview/usr/lib  "

and change name of  "liblinxdevice_RPI2.so" to" liblinxdevice.so".


good luck
iman gholizadeh

Message 9 of 10
(1,305 Views)

Hi sir 

        I change the name from "liblinxdevice_RPI2.so" to" liblinxdevice.so"

        But the rspberry pi suddenly disconnected from linx.

        After i connect to linx and i upload a empty vi its working properly.But when i upload example blink vi it again showing same error.

         please help in this error.

0 Kudos
Message 10 of 10
(304 Views)