Showing results for 
Search instead for 
Did you mean: 

Deployment Error When Deploying Labview to Raspberry Pi through LINX

Go to solution

I am using Raspberry Pi 3 with raspbian jessie and installed labview 2014(32bit) in my windows 7 laptop.

Everything goes smoothly as I connect to my rpi using the linx target configuration. The problem is that everytime deploy a vi (I deployed blink), i get this:

Calculating dependencies...
Checking items for conflicts. This operation could take a while...
Preparing items for download. This operation could take a while...
Deploying NI_PtbyPt.lvlib
Deploying LMH-LINX.lvlib
Deploying LMH-LINX.lvlib:Local IO.lvlib
Deploying LMH-LINX.lvlib:Device.lvlib
Deploying LMH-LINX.lvlib:myRIO.lvlib
Deploying LMH-LINX.lvlib:Interaction Parts Kit.lvlib
Deploying LMH-LINX.lvlib:Ultrasonic.lvlib
Deploying LMH-LINX.lvlib:TMP3x.lvlib
Deploying LMH-LINX.lvlib:TCN75A.lvlib
Deploying LMH-LINX.lvlib:PmodTC1.lvlib
Deploying LMH-LINX.lvlib:PmodGPS.lvlib
Deploying LMH-LINX.lvlib:PmodMAXSONAR.lvlib
Deploying LMH-LINX.lvlib:PmodBT2.lvlib
Deploying LMH-LINX.lvlib:PmodGYRO.lvlib
Deploying LMH-LINX.lvlib:PmodALS.lvlib
Deploying LMH-LINX.lvlib:PmodACL2.lvlib
Deploying LMH-LINX.lvlib:PmodACL.lvlib
Deploying LMH-LINX.lvlib:PmodTMP3.lvlib
Deploying LMH-LINX.lvlib:PmodMIC3.lvlib
Deploying LMH-LINX.lvlib:PmodJSTK.lvlib
Deploying LMH-LINX.lvlib:PmodCMPS.lvlib
Deploying LMH-LINX.lvlib:LTC2631.lvlib
Deploying LMH-LINX.lvlib:AD9850.lvlib
Deploying LMH-LINX.lvlib:WS2812.lvlib
Deploying LMH-LINX.lvlib:BlinkM.lvlib
Deploying LMH-LINX.lvlib:SSD1306.lvlib
Deploying LMH-LINX.lvlib:HiTechnic.lvlib
Deploying LMH-LINX.lvlib:HiTechnic.lvlib:Accelerometer.lvlib
Deploying LMH-LINX.lvlib:Servo.lvlib
Deploying LMH-LINX.lvlib:DS1307.lvlib
Deploying LMH-LINX.lvlib:MMA8452.lvlib
Deploying LMH-LINX.lvlib:MMA8451.lvlib
Deploying LMH-LINX.lvlib:ADXL345.lvlib
Deploying LMH-LINX.lvlib:MPU60X0.lvlib
Deploying Raspberry Pi 2 B(successfully deployed target settings)
Deploying TagReturnType.ctl (1.32 K)
Deploying whitespace.ctl (1.32 K)
Deploying LMH-LINX.lvlib:Device.lvlib:TCP Config.ctl (1.58 K)
Deploying LMH-LINX.lvlib:Platform.ctl (1.32 K)
Deploying Trim (3.18 K)
Deploying LMH-LINX.lvlib:Channels.ctl (4.50 K)
Deploying Search and Replace (8.40 K)
Deploying Find (11.43 K)
Deploying LMH-LINX.lvlib:Device.lvlib:LINX VI API (2.93 K)
Deploying Format Message (6.47 K)
Deploying NI_PtbyPt.lvlib:Update (7.55 K)
Deploying (3.83 K)
Deploying LMH-LINX.lvlib:Device Firmware.ctl (2.51 K)
Deploying LMH-LINX.lvlib:Device.lvlib:Bit (5.18 K)
Deploying LMH-LINX.lvlib:Error Type.ctl (1.32 K)
Deploying VISA Configure Serial Port (Instr).vi (7.45 K)
Deploying LMH-LINX.lvlib:Interface.ctl (1.32 K)
Deploying NI_PtbyPt.lvlib:Mean (10.42 K)
Deploying LMH-LINX.lvlib:Loop (4.69 K)
Deploying Check Special (5.77 K)
Deploying DialogTypeEnum.ctl (1.32 K)
Deploying LMH-LINX.lvlib:User Platform.ctl (1.32 K)
Deploying LMH-LINX.lvlib:Get (3.61 K)
Deploying LMH-LINX.lvlib:Clean Error Call (13.03 K)
Deploying DialogType.ctl (1.32 K)
Deploying LMH-LINX.lvlib:Device Data.ctl (2.37 K)
Deploying Error Code (4.39 K)
Deploying General Error Handler Core (47.32 K)
Deploying General Error (10.75 K)
Deploying LMH-LINX.lvlib:Device.lvlib:Firmware Version.ctl (1.43 K)
Deploying LMH-LINX.lvlib:Device.lvlib:Packet Number FGV Action.ctl (1.32 K)
Deploying Error Cluster From Error (9.29 K)
Deploying LMH-LINX.lvlib:Device.lvlib:LINX Device Config.ctl (5.16 K)
Deploying LMH-LINX.lvlib:Device.lvlib:Serial Set (6.57 K)
Deploying LMH-LINX.lvlib:LINX Ref.ctl (5.32 K)
Deploying LMH-LINX.lvlib:Local IO.lvlib:Load Device Channels.viLMH-LINX.lvlib:Local IO.lvlib:Load Device loaded with errors on the target and was closed.
Deployment completed with errors


How can I complete deployment without having any errors?

0 Kudos
Message 1 of 10

You might also want to post this to the LabVIEW MakerHub and hopefully someone familiar with it will see.

0 Kudos
Message 2 of 10

I have tried to post this to the labview makerhub forum last week but it was not posted, it needs to be accepted by the moderator before being posted. And as I have searched, its admin last visited the site a month ago. 

0 Kudos
Message 3 of 10
Accepted by 24601

I was having the same issue. The fix for me was here;

Navigated to the :/srv/chroot/labview/usr/lib directory

and ran the command;

ln -s ./ ./


I also set up manually before hand as suggested further on.

Message 4 of 10

@geovogel wrote:

I was having the same issue. The fix for me was here;

Navigated to the :/srv/chroot/labview/usr/lib directory

and ran the command;

ln -s ./ ./


I also set up manually before hand as suggested further on.

Thank you! Your instructions made the steps in the labviewmakerhub forum easier. 

However, everytime I try running a VI, before I can even click anything in the VI's panel, the connection to my raspberry pi will suddenly be lost. Do you have something in mind on how to fix this?


My primary guess for this error's culprit is my internet connection with my rpi; it is connected to the internet through lan cable. I plugging out the cable and plugging it in again, but the problem still persist. I also tried rebooting my rpi, but the same happened.

0 Kudos
Message 5 of 10



So any program that communicates with your Raspberry Pi is causing it to lose connection?


That sounds like an unhandled error or something else unexpected in the software. Try using highlight execution to see at what point the connection is lost.



0 Kudos
Message 6 of 10

Yah..I am also getting the same error.

Before this "

I was having the same issue. The fix for me was here;

Navigated to the :/srv/chroot/labview/usr/lib directory

and ran the command;

ln -s ./ ./


Pi was connecting. After setting up this code, it shows an error.


Does any one sorted out this issue?


0 Kudos
Message 7 of 10

Hi Vancamp


Did your problem gotresolved?


Pls let me know

0 Kudos
Message 8 of 10

hi every one

go to this directory 
"    /svr/chroot/labview/usr/lib  "

and change name of  "" to"".

good luck
iman gholizadeh

Message 9 of 10

Hi sir 

        I change the name from "" to""

        But the rspberry pi suddenly disconnected from linx.

        After i connect to linx and i upload a empty vi its working properly.But when i upload example blink vi it again showing same error.

         please help in this error.

0 Kudos
Message 10 of 10