LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Deploy WebService

¡Buenas a tod@s!

 

Estoy programando varias VI como servicios web, y no consigo ver la manera de poder crear dichos WS en un servidor remoto. Mediante New>>WebService(RESTful) (en las Build Specifications de un Proyecto) creo los WS pero en el mismo PC dónde estoy desarrollando. Y quisiera poder desplegar los WS en otro ordenador dónde también tengo el WebServer configurado.

 

Consejos, sugerencias... ¡son siempre bienvenid@s!

 

¡Saludos!

Francisco José Gómez López
Software Engineer
0 Kudos
Message 1 of 10
(1,726 Views)

Hello everyone!

 

Sorry for the previous post. I didn't realized that this wasn't a spanish comunity forum (I any moderator can delete the previous one... better!). So, my question/doubt is the following:

 

Is there any way to deploy a WebService in a remote Server. The idea is to work in one computer and not to send via ftp (or other stuff) the .vi file to the server and do the deployment there (where I have the VI Server and Web Server configured already)

 

Is it possible?

 

Thank you so much!

Francisco José Gómez López
Software Engineer
0 Kudos
Message 2 of 10
(1,703 Views)
Dear Fran, Can you please elaborate more about your application.
Chief Technical Engineer
VSK Test Solutions
0 Kudos
Message 3 of 10
(1,700 Views)
Well, I'm afraid there is nothing more to add. I'll try to explain it better. I'm developing my Web Services in a PC. These VIs are under a Project so, through Build Specifications>> New>> Web Service (RESTful) I can deploy my VIs as Web Services in the same PC I am working. I want to deploy my Web Services in another PC from my current project. Is it possible? The way I deploy my Web Services in the remote PC (let's say server) is creating the Project in the Server, adding the VIs manually to this project and building them as Web Services in the Server. What I want to do is the same thing, but from my PC. Hope it helps to make my doubt clear. Thanks.
Francisco José Gómez López
Software Engineer
0 Kudos
Message 4 of 10
(1,697 Views)

It seems you need to deploy your web service on the remote machine, for which you need make an installer on the development machine and install this application on the remote machine, it should work as web service on the remote machine.

 

 


You wrote:

The way I deploy my Web Services in the remote PC (let's say server) is creating the Project in the Server, adding the VIs manually to this project and building them as Web Services in the Server.


As i understand remote pc is not Labview development PC, so how you can create the project on that machine.

 

Please clarify.

 

 

Chief Technical Engineer
VSK Test Solutions
0 Kudos
Message 5 of 10
(1,681 Views)
Because I install LabVIEW in the remote PC in order to configure the VI Server and Web Server. Or can I set up the Web Server without installing LabVIEW?
Francisco José Gómez López
Software Engineer
0 Kudos
Message 6 of 10
(1,676 Views)

For security reasons, LV does not allow you to deploy services from one PC to another thru the LabVIEW Project.  You must create an installer to do this. Which is easy to do.

 

From your LabVIEW project on your dev machine, right click on Client Specifications, and choose "installer".  From the intaller build spec properties, add your web service build spec as a source to the installer. Doesn't matter what the destination folder is, that is up to you.

 

Then just build your installer. Once built, you can move the installer EXE over to your production server, and run it. Once the installer finished, your web service will be deployed with all required dependencies.

 

There is no need to have the full LV development installed on your production server. The installer you build above will install all necessary dependencies for your web service to execute.

 

Hope this helps.

Message 7 of 10
(1,671 Views)

You have to configure web server settings on the development machine and build your web service application

Installer itself creates an configuration file (.ini), which will have all your configurations and same will apply on the remote machine.

 

Procedure for creating an installer, 

LabVIEW 2009 : http://digital.ni.com/public.nsf/allkb/62B9C2D5C91EE8B28625778800609FF2?OpenDocument

LabVIEW 8.6: http://digital.ni.com/public.nsf/allkb/0335B60BA1B6485E86257788006066DF?OpenDocument

 

Also have a look on the link to know how to creating , publishing, deploying and managing web service.

 

http://zone.ni.com/reference/en-XX/help/371361E-01/lvconcepts/webservices/

Chief Technical Engineer
VSK Test Solutions
0 Kudos
Message 8 of 10
(1,666 Views)

The above linked installer articles are outdated for LV 2011. They also describe how to include a web service inside of a LV Built Application, not an installer. It's a subtle difference, but important.

 

In your case, you just need an installer for a web service, not a LV built EXE, so stick with the simple instructions in my post.

 

Let us know if any of this is helping.

 

-Jared

0 Kudos
Message 9 of 10
(1,652 Views)

If you problem solved, thats great.

It doesnt matter to whose solution you have to stick.

Chief Technical Engineer
VSK Test Solutions
0 Kudos
Message 10 of 10
(1,642 Views)