LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Delete plot definitions from chart

Hi Thoric,

 

I don't understand what do you mean by changing the number from 11 to 12 (on first page)? Do you mean changing the number of "Plots shown" under the "Properties" ->"Appearance" ? That doesn't work for me... The plot definitions are still there even I deleted the name of the plot.

 

Sam

0 Kudos
Message 21 of 25
(1,561 Views)

I have confirmed this behavior - changing the plots shown value in the graph properties in LV 2009 has no effect - changing it in LV 8.5 removes any nameless plots from the definition list. Also of note is that in LV 2009 at least you can't have nameless plots - they show up as "plot #".

 

So is there a way to delete plot definitions in LV 2009? I've not seen one, and I have the same use case as Thoric originally posted here. Since in my application I might theoretically have to deal with over 2500 plots, I would really like to get rid of the ones not in use and not have them on the scroll list...

CLD using LV, DSC 8.5-2009, RT 8.5
Ghoti!
0 Kudos
Message 22 of 25
(1,486 Views)
I had an example of this behavior, and NI has opened a CAR on it.  I cannot lay my hands on the email at the moment but have attached the example I submitted to NI (LV2009), but confirmed that it also works in 8.6.  Following the directions should get you a programmatic work around.

Paul <--Always Learning!!!
Philips Respironics.
sense and simplicity.
Browse my sample VIs?
Message 23 of 25
(1,477 Views)

Are there any news regarding this issue?

 

I tried the cell_plot_tester2.vi example: it works as long as you don't increase the number of plots by dragging the border of the legend.

Lets say now you have 3 plots shown in the legend. After that, number of plots you can see in the properties of the graph is always greater or equal to 3, regardless of how many plots you remove by a second FOR-Loop. There is also no way to remove this plots by editing properties. Neither reducing the number of plots by dragging the border of the legend helps.

 

The same behavior in both LV 2009 and 2010.

Seems like a bug?

 

 

0 Kudos
Message 24 of 25
(1,262 Views)

Hi aptb,

 

As a general word of advise, you may receive a much better response if you post your questions as a new thread since this thread is now relatively old. You can than link this thread in your new post.

 

Best Regards,

 

Christian Hartshorne

0 Kudos
Message 25 of 25
(1,242 Views)