From 12:00 AM CDT Sunday, October 17 - 11:30 AM CDT Sunday, October 17, ni.com will be undergoing system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Datasocket not included in LabVIEW runtime?

Hello,

 

According to this 2018 KB entry "The LabVIEW Run-Time Engine package includes several installers, including NI DataSocket."

 

I've just installed 2020sp1 runtime on a new machine. I mind you that there's no configuration options given at the install time.

 

I then run a compiled LavVIEW 2020 app that returns "Cannot load dataskt.llb application" error 1143. Another KB suggest to check if Datasocket is installed - it is not.

 

How do I fix it?

0 Kudos
Message 1 of 6
(384 Views)

I also tried to manually install Datasocket though the package manager as described here. but none of the packages mentioned at that link appear in the manager after turning the feeds on.

 

How can I get my money back?

0 Kudos
Message 2 of 6
(353 Views)

@Fedor wrote:

I also tried to manually install Datasocket though the package manager as described here. but none of the packages mentioned at that link appear in the manager after turning the feeds on.

 

How can I get my money back?


Just contact your sales rep.  Honestly, though, they'd probably want to do some troubleshooting with you before they give up the money.

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 3 of 6
(307 Views)

This knowledge base article says that DataSocket is installed together with LabVIEW (development) since LV19. However if you have the Application Builder module, you can include Datasocket as a separate component in an Installation Build (I verified with LV19 since i don't have LV20).

Paolo
-------------------
LV 7.1, 2011, 2017, 2019
0 Kudos
Message 4 of 6
(269 Views)

Thank pincpanter! I was familiar with the  article, but I wanted to be able to run a standalone app that does not came with its own installer. 

 

In the end, I had to manually edit the feed urls as described in the other article I linked to point to 2020 LV development system, then search for the 2020 datasocket in the feed.

 

NI made what should have been a simple task of adding a missing library into multi-day research project.

 

Grade: F 

0 Kudos
Message 5 of 6
(229 Views)

Ah! Honestly I did not read the articles you linked. I just assumed you someway did not know about, since it's unlikely that NI would refund for any issue which has a clear workaround. Maybe yours was a semi-ironical rant?

Paolo
-------------------
LV 7.1, 2011, 2017, 2019
0 Kudos
Message 6 of 6
(224 Views)