Showing results for 
Search instead for 
Did you mean: 

Datasocket Select URL broken


I seem to have broken the front panel datasocket capability of Labview.
The datasocket system itself seems to work ok, with the installed examples operating as expected.

However, if I try editing a control and enable data binding to Datasocket, when I click on the 'Browse' option, Labview asks me to install LV runtime Engine 7.1.1 and then hangs there until I kill LV through task manager. I am running Windows 10, so I would not expect the RTEv7.1.1 to work correctly.


I have tried running a VI with the DataSocket Select on it and the same hanging and waiting for the LV RTE7.1.1 behaviour occurs.

If I type the URL into the 'path' field of the dialog box, I get no problems, it just seems to be the interactive browser select that gives the problem.

This happens in both LV8.5 and LV2015(32-bit) on my machine, it does not occur in the 64 bit version on LV2015.


I've tried reinstalling LV2015a and also downloading and installing the latest drivers set for LV, but it made no difference to the problem,


Any ideas?


0 Kudos
Message 1 of 2

Hi Dave,

Thank you for reaching out, a couple of questions to help better troubleshoot this:

What example are you using and in which LabVIEW version?

Does it make a difference if you select Read or Write or Read/Write?


You mentioned about windows 10 and not expecting it to work with RTEv7.1.1 but it is also not compatible with anything older than LabVIEW 2015 SP1, as shown here. Therefore it is likely you run into problems using LabVIEW 2015.


Many Thanks,


0 Kudos
Message 2 of 2