From Friday, April 19th (11:00 PM CDT) through Saturday, April 20th (2:00 PM CDT), 2024, will undergo system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.


Showing results for 
Search instead for 
Did you mean: 

Datalog files LV v6.0 & 6.0.2

I saw a few other posts recently about datalog file conversions
between versions, but they didn't mention quite the same problem that I
just saw.
I have an application under 6.0.2 that creates datalog files. I
copied part of the application (a file reader program) to another
computer that has v 6.0. I also copied a file that had been created
under 6.0.2. When I ran the file reader under 6.0, using the datalog
type input to the file dialog function, the file would not appear in the
dialog, as if it was not recognized as a datalog file of the proper
type. The file reader program worked on both computers with that same
file once I had upgraded the 2nd computer to 6.0.2.
Is there a known compatibility issue with datalog files going
kwards from such minor version upgrades? If so, is there a way to
successfully convert them?

Dave Thomson

David Thomson 303-499-1973 (voice and fax)
Original Code Consulting
National Instruments Alliance Program Member
Research Scientist 303-497-3470 (voice)
NOAA Aeronomy Laboratory 303-497-5373 (fax)
Boulder, Colorado
0 Kudos
Message 1 of 2

Thought the upgrade from 6.0 to 6.0.2 is not a large one, it was large enough to require that all VI's need to be recompiled, and also apparently, how the different data types are handled by LabVIEW has changed subtly. This would fit the criteria for why those datalog files aren't showing up, they do not filter as the "correct" data type.

I have verifed your issue and haven't been able to find a workaround, except that all copies of LabVIEW should be upgraded to 6.0.2 as a good general rule of thumb.

Joshua H.
Applications Engineer
National Instruments
0 Kudos
Message 2 of 2