LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Data entry range ignored by numeric control

Hello,

 

I am coding an application on LabView. One of the control accessible by the user is a numeric control situated on the front panel. I would like the value of this control contained in a certain range, say 0 and 100. I accessed the properties of the control and changed the maximum and minimum values in the "Data entry" tab. But when I run the software and try to change the value of this control, the accepted range is 0 to 50. For example, if I change it to 70, it coerces it down to 50.

I tried to change "Response to value outside limits" from coerce to ignore but it did not help.


I also tried to set the maximal accepted value of this control, connecting the constant "100" to one of its property nodes but it did not help.

 

I also tried go back the default -Inf to Inf in the Data Entry tab of the control but it did not help either.

 

I am out of idea and really don't understand why my control applies a different range than the one I set. My LabVIEW version is 14.0.1 (32-bit). I would really appreciate if someone had already seen such problem and knew how to solve it. Thanks!

0 Kudos
Message 1 of 3
(1,381 Views)

Hi vic,

 

whenever you have a problem with your VI you should attach that VI!

 

That being said: check the properties of this control (again)!

Best regards,
GerdW

using LV2011SP1 + LV2017 (+LV2020 sometimes) on Win10+cRIO
0 Kudos
Message 2 of 3
(1,375 Views)

"coerce" is the right setting. Does the control have associated units?

 

Yes, please attach a simple VI that contains the control.


LabVIEW Champion. It all comes together in GCentral GCentral
What does "Engineering Redefined" mean??
0 Kudos
Message 3 of 3
(1,318 Views)