LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Data Plot Error 85

Highlighted

Hello, I read serial data from vacuum sensor. Then i want to plot received data graph received instantly.

 

I added main.vi. And you can see my data out format from .png

According to my data out, how do i choose "scan number" or xy axes values to solve error 85?

Download All
0 Kudos
Message 1 of 6
(299 Views)
Highlighted

I can't open your VI because I don't have LV 2019.

 

Looking at your screenshot, it looks like your PC is setup to use that crazy European comma as a decimal point.

The string you are reading as a comma as a delimiter, and a period as the decimal point.

 

My guess is your PC settings are being confused with the incoming data string.  Look at the format string for Scan from string.  There is a setting to specifically define a period as the decimal point no matter what your PC is set to.  Start our format string with %.;  and see if that fixes your problem.

Message 2 of 6
(250 Views)
Highlighted

@RavensFan wrote:

I can't open your VI because I don't have LV 2019.

 

Looking at your screenshot, it looks like your PC is setup to use that crazy European comma as a decimal point.

The string you are reading as a comma as a delimiter, and a period as the decimal point.

 

My guess is your PC settings are being confused with the incoming data string.  Look at the format string for Scan from string.  There is a setting to specifically define a period as the decimal point no matter what your PC is set to.  Start our format string with %.;  and see if that fixes your problem.



Thanks RavensFan for your attention. It's vi. Can you view it this way to solve the error?

Actually i added data on display screen. I should see the same data format in front panel when data receives. (Like that 4.77 x 10^-6) For this, where i should focus on VISA Read or data out in .vi ?

read.PNGdata_out_display.PNG

0 Kudos
Message 3 of 6
(211 Views)
Highlighted

Hi bestecf,

 

did you take any of those Training resources offered in the LabVIEW forum header until now?

Then you should have learnt about basic debugging techniques…

 

Actually i added data on display screen. I should see the same data format in front panel when data receives. (Like that 4.77 x 10^-6) For this, where i should focus on VISA Read or data out in .vi ?

So the error 85 has nothing to do with plotting data on a chart.

Instead you should read the error explanation to find the problem source!

 

What is the content of "data out" What does ScanFromString expect?

Why don't you implement some basic error handling? (Again: basic LabVIEW training!)

Best regards,
GerdW
CLAD expired, using LV2011SP1 + LV2017 (+LV2019 sometimes) on Win7+cRIO
Kudos are welcome Smiley Wink

0 Kudos
Message 4 of 6
(202 Views)
Highlighted

@GerdW wrote:

Hi bestecf,

Actually i added data on display screen. I should see the same data format in front panel when data receives. (Like that 4.77 x 10^-6) For this, where i should focus on VISA Read or data out in .vi ?

So the error 85 has nothing to do with plotting data on a chart.

Instead you should read the error explanation to find the problem source!

 

Yes, I know. I want to indicate as another thing. Thanks your advices...

0 Kudos
Message 5 of 6
(197 Views)
Highlighted

I thought I was pretty clear in my message about what to do.

 

The format string, that string constant that goes into the top of the Scan From String.  Make it say      %.;%f  instead of just %f.

 

Actually, your %f was wrong because you are only trying to get one value, but your device is sending two.  Make it    %.;%f,%f 

0 Kudos
Message 6 of 6
(185 Views)