LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

DAQmx Physical Channel VI not showing any Digital Output channels

Solved!
Go to solution
Highlighted

Hello,

I'm trying to output 4 identical digital voltage wave forms simultaneously using DAQmx VIs. I'm running my labview code on a NI DAQPad-6259, and wanted to specify the physical lines to output my voltages to. The problem I hit is that the DAQmx Physical Channel constant does not seem to recognize any digital line, input or output. It does recognize the analog channels, and if I create a task to generate a voltage it recognizes the DO lines, but when it runs it gives me an error proclaiming that the DO lines I set in the task aren't real.

 

Thanks for any help on explaining this.

0 Kudos
Message 1 of 2
(673 Views)
Solution
Accepted by topic author Ramonk

Hi Ramonk,

 

I don't fully understand what you would like to do. You want to output 4 different square waves or what kind of signal? Because I'm not sure you could write a sine wave with the DIO ports. Another thing I could see from your VI is that you may not be too familiar with DAQmx functions and the general form of a DAQ program. For a continuous digital output, you should follow a dataflow as the one on this manual: https://zone.ni.com/reference/en-XX/help/370466AC-01/daqhelp/contdoflow/ you can check that to improve your code. Maybe the fact of trying to configure the channels in each loop iteration is what is messing up the program, or starting the task without ever ending it.

 

Also, here is a link to a document where you can find information on DAQmx usage and programming, that will help you improve you applications and let you have more efficient code: http://www.ni.com/product-documentation/5438/en/ 

 

Regards!

Message 2 of 2
(624 Views)