LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

DAQ card detected, but disappear from device list(MAX)

Hi,
 
I am working with one of DAQ card (PCI-6220) . It is working fine till around 2 days ago when it without any reason the DAQ disappear from the device list(MAX). I check at device manager, it still exist there. Hence , I trying to re-install the driver, it still not showing up on the MAX. I already tring to uninstall the hardware and re-start the computer to see whther the device card is detected. This also shown that the ahrdware have no problem. However the problem still exist. I stil can not detect the card from any labview applications.
 
Could anyone help??
 
Thanks
 
p.s. I use labview 7.1, and windows XP
 
0 Kudos
Message 1 of 7
(2,147 Views)
Hi silver_eagle,

It's possible that the drivers are corrupted, but reinstalling the NI-DAQmx drivers should have fixed that.  You typically want to uninstall the drivers from Windows prior to reinstalling them.  We would also recommend getting the newest version of NI-DAQmx while you're at it.  Also, whenever you are reinstalling drivers, you want to remove the hardware from your PC so that Windows can redetect the hardware correctly and associate the right drivers to it.  Try removing the hardware (with the PC shut down of course), uninstalling the drivers, reinstalling the newest version, and then reinstalling the hardware (again with the PC off).  Windows should come up with the "New Hardware Found" dialog again and install the drivers.  Once this happens, MAX should see the device again.  You may also want to test the card on another PC just in case it happens to be a hardware issue.  Let us know how this goes for you!

Thaison V
Applications Engineer
National Instruments

0 Kudos
Message 2 of 7
(2,132 Views)

Thanks for the reply

I already tried all the advice, and l also check the hardware. The card is alright.

Anyway, at the end I managed to fix the problem by re-install  windows. Still, I would like to know what caused it, and if` there any way to resolve the issue if it happened again without installing windows

Thanks

 

0 Kudos
Message 3 of 7
(2,109 Views)
It's hard to say what the problem could have been.  Did the new hardware found window show up after you re-installed the NI-DAQmx driver?  If not, it would appear to be a problem with Windows itself. 

Regards,
Micaela
Micaela N
National Instruments
0 Kudos
Message 4 of 7
(2,094 Views)

Hi,

From the beginning( before re-install the windows) in device manager it show that the DAQ exist and work fine, however MAX any any other labview program can not access the daq. Before re- install, i alredy try to restore the window to the day the labview installed, and also re install the newest driver, but seems not working.

 

Anyway now it is working fine, and hopefuly i do not need to re install window again in the future.

Thanks

0 Kudos
Message 5 of 7
(2,088 Views)

I am having the exact same problem!  Please don't tell me I have to reinstall windows!

0 Kudos
Message 6 of 7
(1,663 Views)

Hai , i am Manick.....I installed PCI7830R in my PC.... in MAX it detected under device and interfaces...but card submenu properties are not getting opened when i right click it..... i am using Labview 10..... and also similiarly when i used DAQ icon , 7830R card not getting detected uder the Physical Channel list.... so i am not able to select channels to code a VI..... but the card 7830R getting detected when i am using Project Explorer.....y this happen..... i just use Project Explorer to create FPGA Bit Files..... rarely i want to Mapped SCB68 with this 7830R card ...so in order to do that i want my card to detect in MAX.... how could i solve this now????

0 Kudos
Message 7 of 7
(1,647 Views)