Showing results for 
Search instead for 
Did you mean: 

DAQ No Signal in Test Window and 200284 Error



I'm working on a university project to control the speed of a motor using LabVIEW.


My program seems to run successfully only the first time it in the day. If I try to run it again I get a 200284 error ("Some or all of the samples requested have not yet been acquired").  I've tried resetting the computer, and the devices in MAX. 


When I open the 4472 test panel in MAX, choose:


Coupling: DC

Rate: 20000

# Points to read: 2000 points

Aqusition mode: Continuous
Autoscale Chart: <check>


and press start, there is no waveform displayed on the chart. Occasionally when it does display a waveform it has a large amount of noise (spikes of up +-10V) when the reading should be 0V.


We have a PXI-1000B computer with a PXI-4472 DAQ card.  We are using LabVIEW 8.6 and MAX version 5.3.


I'll welcome any suggestions!


Thanks in advance!

0 Kudos
Message 1 of 13

Hi ElecEng,


You said that it does run successfully the first time. Do you get a proper waveform in MAX before you try running the program? 

0 Kudos
Message 2 of 13

Hi Burrito,


Thanks for the fast reply!


I haven't tried that yet. I'll try today.


I'll also mention that a Korenix Jet I/O 6520 is being used for analogue output. This is connected over Ethernet and writes to this are in the same while loop as the DAQmx reads. I'm not sure if this could be related or not.  

0 Kudos
Message 3 of 13

I checked the signals in the MAX test panel today before running the program.


There was a large amount of noise on signals that should be 0V.  Some channels had + - 3V dips others had + - 10V.

0 Kudos
Message 4 of 13

The program ran successfully once without too much noise.


Now the program runs but with much more noise and it is very laggy.  The MAX test panel only shows a signal for finite aquisition.  It takes more than five seconds to display and there are spikes of + - 10V on all channels now.





0 Kudos
Message 5 of 13

I can't say I'm familiar with Korenix products. I'm not sure how that could be affecting your results.


Would it be possible for you to post a screenshot to give a better idea of what you're seeing?

0 Kudos
Message 6 of 13

Currently, I'm not seeing any signal.


It was working fine for a few days, and now it has stopped working again.  The waveform chart has been blank for at least 15min now (like in the screenshot).  All the other channels are the same (ai0-ai7).


Every time I press start it becomes grayed out but no waveform appears.  The same is true for "Acquisition Mode: Finite".  It appears to be waiting for the captured data, but nothing arrives.


So far today, I've tried: reseting the 4472 in MAX; reseting the computer; and turning everything off and starting agian after lunch...


I have ruled out the Ethernet connection as a problem.  It works fine by itself without data acquisition.  In my main program, an Error-66 comes up for that first because the Ethernet connection times out as the loop is waiting for the data acquisition read (I believe anyway).



0 Kudos
Message 7 of 13

It suddenly started working today after I posted the above message. Then it stopped working for about 5 minutes, and started working again.


The system needs to be more reliable than this... I am running a motor from the JET I/O. The LabVIEW program crashed yesterday while the motor was running... I have since put a switch in to set the motor driver voltage reference to zero!



0 Kudos
Message 8 of 13

And there is nothing changing in between the times when it works and when it doesn't?


It almost seem like you have a bad physical connection somewhere. Is there any wiring in your system besides your Ethernet connection? Do you have any duplicate parts you could switch for the ones you are currently using?

0 Kudos
Message 9 of 13

Thanks for your help so far Burrito!


There's nothing that I can think of that is changing between it working and it not working.  There's quite a bit of wiring for signal conditioning before the DAQ.  There are not many parts we can change around.



I have tried "Reset Configuration Data". MAX found the DAQmx devices again PXI-4472 and PXI-6602, suggesting there is a good connection to those.


However, I cannot seem to get a signal displayed in the PXI-4472 test panel.  Clicking on "Self Test" gives the message "The device has passed the self test".  I have also tried resetting the device. 


I have identified the chassis (PXI-1000B) and PXI system (PXI-8196).  However in the PXI-1000B "Chassis 1" window, all the slots are "<Unknown/Empty>", even those with the PXI-4472 and PXI-6602 cards in them! 


I'm wondering if PXI-4472 has timed out and isn't taking measurements, or if it isn't configured correctly. 

0 Kudos
Message 10 of 13