Showing results for 
Search instead for 
Did you mean: 

DAQ Input Signal kept rising and stop at Max Voltage when run with nothing attached

Go to solution

I just installed PCI 6229 card and a BNC 2110 (Labview 8.6v). When I started the DAQ Input, the signal kept rising and stop at max Voltage  (10V) when run with nothing attached (instead of fluctuating at around 0). Just wondering what's wrong with it and how to solve it. Terminal configuration was "Differential"

I just created an input DAQ with a scope and while loop to look at it. Please let me know if I do anything wrong



0 Kudos
Message 1 of 8

If there is nothing connected to the inputs, it will float high.  This is normal.  The inputs probably go to some op-amp circuits which will drift high or low depending on the circuit.  You should always terminate inputs.  Put a high resistance to ground (100K) on the input line and you will read 0v with nothing else connected.  It is common practice to ground all unused op-amp inputs when designing a circuit.


- tbob

Inventor of the WORM Global
0 Kudos
Message 2 of 8
I also use the DAQ output and signal generator from labview to create a DC signal of 3V. I basically loop the Input AO 1 and AO 2 from BNC connections together. It still shows max value. It doesn't response to anything I connect to it. It always go to max. Is this hardware faulty?
0 Kudos
Message 3 of 8

Sorry for confusion. What I was trying to say was I connected AO 1 (3V DC signal) and AI 1 (input) together to see if the reading will read 3V. It doesn't seem so, it still shows 10V


0 Kudos
Message 4 of 8
Accepted by MrCoolMan


I just re-read your original post.  Why do you have the terminal setting to differential?  This sounds like a single ended setup to me.  Change the terminal setting to RSE.  With a differential setting. you need to connect one source to AI1 and another source to AI9.  The difference between the two will be reported.  With RSE, only AI1 will matter and the voltage with respect to ground will be reported.  Make sure you have your AO ground tied to your AI ground.


Message Edited by tbob on 06-15-2010 05:44 PM
- tbob

Inventor of the WORM Global
Message 5 of 8

Hi Tbob,


i'm facing the same problem. My signal keeps rising til max voltage. I connected an NI USB 9162. As you recommend I tried to chance from "differential" to "RSE". For an unknown reason this ist not an option in my drop down menu.

The PreAmplifier I attached gives the option to switch to a "differential input" Do you see there any room for improvement?





0 Kudos
Message 6 of 8



1. Appending to a 4-year-old thread which has been marked solved may not get much attention. It would be better for you to start a new thread and link to this one if you think the information here is relevant.

2. The USB-9162 is just a carrier - it does not have any Analog inputs. What device have you plugged into the 9162?


The effect you observed is called "ghosting" and results from charging the capacitances in the DAQ device input circuits. The solution is to connect all unused inputs to ground and to drive all used inputs with low impedance sources. If you are using differential inputs, you may also need bias resistors.



Message 7 of 8

Hi Lynn


Thanks for you advice so far.


The device I plugged into the USB-9162 is called "NI 9215 with BNC". To this device I plugged a Mistras R6D sensor trough the Mistras 2/4/6 C pre-amplifier.


As I'm not a pro in electronics I might ask you to help along wether this could work out or not. If not you might give me a hint what to do instead.



0 Kudos
Message 8 of 8