LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

DAQ Assistant error of mismatching channels

Solved!
Go to solution

Dear Sir,

 

I was trying to send the digital data. Actually i just converted the numeric to boolean array that boolean array may take 8,16,32,64 bits. 

and i am using 6143 daq board so that in daq assistant i choose all digital output i.e 8 output in generating signal option. all connections are fine.

 but when i run that program it showing the error of mismatching channels says that the sink has 8 channels and the data has 32 channels. what i think that this assumes every bit as channel. but dont know how to solve this error.

 

please help me in this regard and find the pic of error.

0 Kudos
Message 1 of 3
(1,077 Views)
Solution
Accepted by topic author vicky2889

Please attach an actual screenshot rather than a 5 MB photograph of your screen.

 

It doesn't make sense that you would use a Double precision floating point control for something that is used for integers and boolean/digital outputs.  A double precision is 8 bytes, 64 bits, and the underlying binary value of that control is not really human readable when compared to the value that is displayed.

 

Apparently, the Number to Boolean Array limits itself to 32 bits, for floating point numbers.  If you wired in a 64-bit integer, you'd get 64 element boolean array.  U32 or I32, 32 elements.  U8 or I8, 8 elements, then you would not get the DAQ Assistant error.

 

Long story short.  Change that numeric control to a U8, unsigned 8 bit integer data type.

 

 

0 Kudos
Message 2 of 3
(1,046 Views)

thanks for your suggestion.

for this i have changed the size of reshape array to 8 and the problem solved by this.

0 Kudos
Message 3 of 3
(993 Views)