LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Create and Deploy I/O Server - Modbus library (Labview 2013)

Highlighted

Hi everyone,

 

I have a project in LabVIEW 2010 which includes I/O Server for ModBus communication, which works fine and only have LabVIEW, FPGA and Real Time Modules installed on the PCs.

 

Porting this application to LabVIEW 2013 with the same modules (FPGA and Real Time), The communication is not working anymore, I can deploy my library but no connection is established (View through the Distributive System Manager) with the PLC, but I can Ping the PLC.

 

I noticed that on LabVIEW 2010, I could do new >> I/O Server, but not on LabVIEW 2013.

Googling, I found this link Cannot Create New I/O Server in LabVIEW Project,

I found that to create and I/O Server, I only needed LabVIEW Real Time (I have the licence), or LabVIEW DSC(I have no licence).

 

Is there something else I need to install ?

Do I need the Real Time licence to only deploy and use the shared variable ?

 

Thanks

0 Kudos
Message 1 of 3
(1,235 Views)

Hi,

 

Do you have these files on your LV 2013 computer ?

 

<LV>\resource\Framework\Providers\IOServer.mxx

<LV>\resource\Framework\Providers\IOServer.mxxlic

 

Installing LabVIEW and LabVIEW RT is enough to be able to create I/O servers.

 

Regards,

Valentin
Certified LabVIEW Architect
Certified TestStand Architect
Certified LabWindowsCVI Developer
National Instruments France

0 Kudos
Message 2 of 3
(1,103 Views)

Hi Valentin,

 

Thanks for your reply,

 

Actually we formatted  and reinstalled the whole system from another DevSuite than the one we had, and it worked.

 

However, we had two PCs, for the update (LV 2010 to LV 2013), and one PC's installation remained with the issue (we didn't reinstalled it !).

This one didn't have the files you listed, but had the following lic files:

In the <LV>\ressource\Framework\Providers\MndLicFiles folder

 - IOServerPlugin_alarmprt.mndlic

 - IOServerPlugin_calccsrvr.mndlic

IOServerPlugin_dataset.mndlic

- IOServerPlugin_epics.mndlic

- IOServerPlugin_epicssrv.mndlic

- IOServerPlugin_mbslave.mndlic

- IOServerPlugin_modbus.mndlic

- IOServerPlugin_opc.mndlic

- IOServerPlugin_visl.mndlic

 

After I copied the files and it I could now create and I/O Server library.

 

We did try reparing but it didn't worked.

Also this PC still has LabVIEW 2010, Labview 2011, LabVIEW 2014 folders, despite their desinstallation.

 

Do you know why those files weren't create during the installation ?

 

0 Kudos
Message 3 of 3
(986 Views)