LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Convert Labview 2002 VI to Labview 2020

Solved!
Go to solution

I need to convert or Run a VI developed in 2002 Version on Labview 2020.

Is there anyway i can get a conversion Kit or which all parts i need to focus while converting?

0 Kudos
Message 1 of 6
(514 Views)
Solution
Accepted by topic author Jen_Joy

Option 1: Use the Version Conversion board.


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
0 Kudos
Message 2 of 6
(496 Views)

What version is "LabVIEW 2002"?  Back then, the year was not part of the version number.  I estimate it would have been about LabVIEW 6.

 

This chart will help to tell what you need.

 

https://www.ni.com/en-us/support/documentation/supplemental/09/how-to-upgrade-or-revert-a-vi-to-a-di...

 

If it happens to be LV 5.1, then you need to open it and save it in a version between 6.0 and 8.2.  Then you can then open that one in versions newer than 8.2

0 Kudos
Message 3 of 6
(476 Views)

Hi Jen,

 

there is no "2002 Version": the years in the LabVIEW version number started with LV2009…

Best regards,
GerdW

using LV2011SP1 + LV2017 (+LV2020 sometimes) on Win10+cRIO
0 Kudos
Message 4 of 6
(472 Views)

Hi GerdW,

 

Thanks for the reply.

 

Sorry i made a typo. Its 2012 , not 2002.

 

While i open 2012 VI on a 2019 version, it is showing errors in calling libraries.

0 Kudos
Message 5 of 6
(451 Views)

2020 will open 2012 just fine.

 

If you are getting errors because of missing libraries, that means you don't have something installed.  What do the error messages say?  What libraries?

 

Perhaps they are instrument drivers you need to download.

0 Kudos
Message 6 of 6
(446 Views)