LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Control text converted to plain (LV 2010 to 2011)

Highlighted

When trying to convert a sizeable application from Labview 2010 (initial version) to Labview 2011 I noticed that the text of many of the (ring) controls are converted from bold to plain.  The application contains several font sizes and styles.

 

Also I had to prevent conversion of the 13pt application font used in the application to the standard 15pt.

 

Is it possible to keep the font style of my controls going from LV2010 to LV2011?

0 Kudos
Message 1 of 4
(859 Views)
Highlighted

This sounds like you changed the "System Font", or "Application Font" in your LV2010 settings. You can copy those lines from LabVIEW 2010's labview.ini file to LabVIEW 2011's labview.ini file. This file is in the same directory as the LabVIEW executable. Or, you could just open up the Tool->Options dialog on 2010, see what you set the fonts to, and do the same thing on 2011.

0 Kudos
Message 2 of 4
(849 Views)
Highlighted

Nope, I don't have a Labview.ini file anywhere.  Also the font settings at Tools->Settings are all default.

 

I am moving my development environment from XP to Windows 7.  I noticed topics about font (size) problems in Windows 7, but didn't see anything about font style changes.

0 Kudos
Message 3 of 4
(843 Views)
Highlighted

@Ettepet wrote:

Nope, I don't have a Labview.ini file anywhere.


You have to have a labview.ini file. Like I said, it's in the same folder as labview.exe.

 

Yes, Windows 7 uses different fonts. To get the same fonts as XP add the following lines to the labview.ini file:

 

appFont="Tahoma" 13
systemFont="Tahoma" 13
dialogFont="Tahoma" 13

 

You should also check to see if your Windows 7 theme is what's causing the problem. That's also been known to cause issues like what you are seeing.

0 Kudos
Message 4 of 4
(833 Views)