LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Continuity Test Not Passing Pin 1 (NI PCI-6509)

Hello all, 

 

I have a continuity testing program and cart at my place of employment that suddenly stopped working. It fails immediately on startup with the first test point. 

 

We're using a NI PCI-6509 board on Dev1. I've checked all continuity from the test harness, the AMP connector box, and the ribbon cable while it's all connected. We've even checked the ribbon cable outside of it being plugged in. I've also went in and configured the test panel. Everything is physically there for it to work.

 

No matter what I've done I still get a fail on the part because it seems it won't proceed from 1 (e.g. P1 to P4-3). Switching "known working" 6509 cards, harnesses, EVEN switching working boxes for the AMP connectors from a working cart I still get the error. We just got a brand new PC for the test cart and I am STILL having the same error, with a fresh set of installation and files for the cart. (Directory and cable catalog for testing).

 

Now, a lot of my error in diagnosing this issue is that I'm pretty green with this equipment. I might be off with something as little as a few clicks in the software under NI-MAX. 

 

I know I'm missing something and I do appreciate any input on the matter. 

 

-JJ

 

 

0 Kudos
Message 1 of 5
(1,234 Views)

Hello JJEC,

 

Are you running code that is failing or is the device failing in NI MAX?

 

Also, have we tested that the card works fine with a simple LabVIEW example or NI MAX test panel?

Niki Budgell | Product Planner - SW Management | NI
Message 2 of 5
(1,178 Views)

Good Morning, Niki, 

 

Everything looks good in NI MAX. All outputs show up on the input lines. We checked voltages coming from the card and everything reads 5 Volts from every port and line that we need from the card. 

 

We even swapped to a new card yesterday just to double check and see if we had false positives from the former card. I installed all new software/drivers from NI.com, and test files from a working cart (mobile test bench). I haven't gotten into writing any LabView software yet, so I'm unable to see what the program is doing under the hood. Every piece of hardware, other than the card, has been tested on a working bench. It passes everything we've put on it with the other tester. The AMP connector box, ribbon cable, and harnesses all work on a known working machine. We even put our own 5V to pin 1 to see if it was something to do with hardware output, but the program immediately fails without hesitation no matter what we do.

 

Lastly, I might have missed saying this, but the new card is also a known working card from another prior installation. 

 

 

Thank you for your assistance and any insight on the matter, 

 

JJEC 

 

 

0 Kudos
Message 3 of 5
(1,167 Views)

Hello,

 

Is the program throwing any error or pop up message? If so, can you upload a picture?

Niki Budgell | Product Planner - SW Management | NI
0 Kudos
Message 4 of 5
(1,148 Views)

Hello,

 

As it turns out, the head engineers are rewriting the entire program. The only error that would pop up was it failing on being able to test past pin 1. Part would "fail" without any other information.

 

It was just that one cart and I wanted to see if I would be able to fix it. I didn't know that a whole new program was being written for the machines we're setting up. 

 

I really appreciate your help with the matter. 

 

-JJEC

0 Kudos
Message 5 of 5
(1,130 Views)