LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Constant wait cursor when editing with LVOOP

That's what I had attributed it to Lea. Although I only have 4 levels in the class hierarchy, and while there's about 300 VIs in all of my classes combined, it really shouldn't be anything that LabVIEW can't handle. Also, it happens when editing a VI in a class that has no other classes inheriting from it.

 

I don't know if this is related, but I also have 2 classes in this project that never save correctly. Every time I close the project it tells me they have unsaved changes, I can do a save all over and over again, it continues to save those 2 lvclass files.

0 Kudos
Message 11 of 42
(393 Views)

@marc A wrote:
I also have 2 classes in this project that never save correctly. Every time I close the project it tells me they have unsaved changes, I can do a save all over and over again, it continues to save those 2 lvclass files.


I'd say that it is a definite possibility that they are behind the behavior.

(^^ sounds like a politician speaking, doesn't it?^^)

 

What would be the impact of removing those 2 classes?  Maybe creating a new class and moving all the objects to the new classes, then deleting the original 2.  Afterwards, renaming the classes. 

Message 12 of 42
(391 Views)

Hi Marc A,

 

I definitely agree with Ray.R.  Give his suggestion a try and let us know what happens.

 

Have a great day,

 

Chris V

Applications Engineer
National Instruments
0 Kudos
Message 13 of 42
(364 Views)

I'm trying to do this, but it's becoming a huge pain. Several times LabVIEW just hung while making a new class and moving the members. Once I got most of them moved, they still have front panel objects of the old class and it won't let me replace all instances with the new class, so I'm going to have to go though each VI individually. There really needs to be better LVOOP tools to handle things like this, but that's for another thread.

 

I'll let you know if this works, although I can tell I'm about to give up. I did just install 2011, so maybe when moving the project over this will be fixed. I can dream...

0 Kudos
Message 14 of 42
(353 Views)

I doubt that bringing it to LV2011 will fix it.

You can try.  Who knows...

 

As long as you intended to install LV2011 regardless of this issue.. 

0 Kudos
Message 15 of 42
(339 Views)

I ran into too many problems trying to create new classes and copying everything from the old ones so I gave up on that. However, I'm up and running on 2011 and so far it seems like those 2 problematic classes are saving correctly now.

 

The original issue with the wait cursor during editing still persists, though.

0 Kudos
Message 16 of 42
(333 Views)

I spoke too soon earlier...

 

I am starting to see similar effects.

 

I was placing boolean constants on the block diagram, and it now takes approx 2 seconds to appear.

I use the "Position/Size/Select" cursor to place the object (TRUE boolean constant) and the "Operate Value" cursor appears while the object is being placed on the block diagram. Well... the "Operate Value" cursor is normal when placing a constant on the BD, but it remains and turns into the rotating icon from Win-7 (wait cursor).

 

I started noticing that this morning.  As I try to repeat it to get more details, it now behaves normally (normal speed).

 

I will try to pay more attention to it.  It may be completely unrelated (PC loaded with many apps, etc).  Although it is running an i7-core processor, it's also running windoze..  So anything can happen. 

 

At the moment, the processors are at 2% with approx 57% memory useage.

 

0 Kudos
Message 17 of 42
(320 Views)

If this post didn't exist, I would probably not have paid much attention to the delay that occurred this morning.  I'd probably take a sip of tea and not think anymore of it..

 

It happened again while deleting a subvi.  This time I looked at the CPU performance and noticed an unusually high peak.  Not sure what it means, but at this point, in my situation, I am not sure that it is necessarily an issue with LabVIEW.  I tried repeating it, but the CPUs are all idling at around 3% when adding or deleting an object.  It is very much random in my case and I suspect that it is "interference" from another app that does something in a cyclic fashion.

 

Why I am posting this?  Just trying to provide some information that might explain my situation.  As I mentionned earlier, we may have completely different situations.  However, if you can, can you check for any drastic changes in the CPU when you make modifications to your VI?

 

 

Here's the CPU peak:

 

0 Kudos
Message 18 of 42
(311 Views)

Yeah, I get a lot of cpu activity when it happens. To test, I'm simply deleting a broken wire on a VI and undoing the action, both produce a wait cursor and a spike of activity.

 

I've also used Process Monitor to see what happens during this wait cursor, and it produces more than 2000 events accessing what looks like every file in my project and a lot in vi.lib. There's clearly something happening that's making LabVIEW think it has to do a lot more work than necessary for every edit.

0 Kudos
Message 19 of 42
(302 Views)

Strangely enough, I see it more often.

I rebooted the PC and it was initially fine. 

Opened a few applications, such as MS Office, Firefox (with 2 tabs open) Notepad, and Exel.  I started noticing the slow behavior.  Especially when saving a VI.

 

As I continue to add code, I am now curious to see if it will progressively slow down.

 

I am also doing a thorough scan of the PC with the Anti-Virus.  Just in case...

0 Kudos
Message 20 of 42
(292 Views)