LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Configuring and Controlling Agilent 332220A signal generator...

0 Kudos
Message 11 of 20
(1,008 Views)
Hi Shivuu,
 
I have done follow your steps,
thanks.
 
 
Sine
0 Kudos
Message 12 of 20
(1,004 Views)

Hi

 

I'm also try to connect the device via usb. but I got error in the "visa io name" that I take from the device usb id

 

could you please let me know How you did it finally?

 

Thank

 

Tomer

0 Kudos
Message 13 of 20
(630 Views)

First, you posted to an old and unrelated thread. Second, you really need to provide the specific error code.

0 Kudos
Message 14 of 20
(624 Views)

Sorry , I didn't want to open new discussion...

 

The error code is - 1073807343

 

Thank you in advance

 

Tomer

0 Kudos
Message 15 of 20
(615 Views)

Are you selecting from thr VISA Resource pull-down menu or typing it in? Does the instrument appear in MAX and windows device manager as USBTMC?

0 Kudos
Message 16 of 20
(610 Views)

 

  1. I type the USB ID that I found in the device I/O manu , There was only one option in the pull down (com1)
  2. I didnt' saw in MAX ( devices tab) any USB devices (I don't know what is USBTMC) .
  3. However in windows device manager the device was recognized. ( I also tried to type the number from the manager ID , in same form of other agilent device that exist in the Labview instrument driver - I typed [usb0::0x0957::0x0407::MY******::instr] ( i dont remembae all numbers.... )

 

Thank you very much

 

Tomer

 

0 Kudos
Message 17 of 20
(603 Views)

Typing the id is not correct. In order to be used in LabVIEW, an instrument has to be USBTMC (Test and Measurement Class). The windows device driver should also reflect this.

0 Kudos
Message 18 of 20
(597 Views)

Thank you

 

How I check if the device is USBTMC ? ( B.T.W , iIn the NI website , they listed USB as one of the interfaces option for the device - Does this imply that the device is USBTMC? )  

0 Kudos
Message 19 of 20
(583 Views)

Lets start with the basics. Did you install the software that came with the instrument?

0 Kudos
Message 20 of 20
(579 Views)