LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Compatibility problems between labview 4.0 and 6.1

I have downloaded a VI to control a TektroniX(2440)oscilloscope from the web.But it was developed in labview 4.0 and run on windows 95.I am trying to use labview 6.1 and running it on windows 2000.I tried including it in the tek2440 llb-VI library and ran ir-It goes into an infinite loop and does not show the output waveform from the scope,as it is supposed to do.Any comments/suggestions are welcome.
0 Kudos
Message 1 of 5
(1,557 Views)
The problem is not between LabVIEW 4 and 6 but between the GPIB drivers. The one you've posted uses Send and Receive from the GPIB>488.2 palette and the one available from NI uses GPIB Write and GPIB Read from the GPIB palette. The 488.2 one uses an integer for the address and is hardwired to 9. NI's uses an address string and is settable from the front panel. Change the old one to match NI's or just use NI's.
0 Kudos
Message 2 of 5
(1,557 Views)
hi,
thanks for your response.
we are able to communicate with the instrument now.but we are interested in capturing the waveform on the oscilloscope,as it is.is there any change we can make in the vi to capture the exact waveform?
Both the vis-the one that i posted yesterday and NI's seem to be analysing something else using the waveform graph.We are not able to exactly capture whatever is there on the scope.
Any suggestions are welcome.
0 Kudos
Message 3 of 5
(1,557 Views)
I don't have a 2440 scope anymore so I can't say what the driver is doing but the VI I downloaded from NI (Tek 2440 Graphed) calls a VI called Tek 2440 RdWfm.vi and that issues the WAV? command which is supposed to retrieve the current waveform. If you're seeing something different, you may have to dig out the scope's programming manual and try out different commands. It appears that the driver is pretty basic and is very old - it has a copyright of 1993. I wouldn't be surprised if there wasn't a lot of work that needed to be done with it.
0 Kudos
Message 4 of 5
(1,557 Views)
My recollection is that when you ask a TEK scope for a waveform, it
sends back either ascii or binary, depending on how it is currently
configured. If it is ascii, it sends the word "CURVE" followed by a
preamble of about 50 to100 characters which describe the current scaling
settings, followed by 4096 comma-separated values between 0 and 255.
Then your code has to parse the preamble to find the scaling to convert
the values back to correct units. I think you can also get it to return
just the data, without the preamble. I remember sending the "CURV?"
command rather than "WAV?" but this was on a TEK2220 and a long time
ago. Hope this gives you some ideas.
-VR

sujani wrote:

>hi,
>thanks for your response.
>we are able to communicate
with the instrument now.but we are
>interested in capturing the waveform on the oscilloscope,as it is.is
>there any change we can make in the vi to capture the exact waveform?
>Both the vis-the one that i posted yesterday and NI's seem to be
>analysing something else using the waveform graph.We are not able to
>exactly capture whatever is there on the scope.
>Any suggestions are welcome.
>
0 Kudos
Message 5 of 5
(1,557 Views)