LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Compatibility of DSC runtime 8.6 and Windows 7

Solved!
Go to solution

Does anyone know if DSC 8.6.1 runtime has a problem  in Windows 7 - 64bit OS similar to the development software?

0 Kudos
Message 1 of 5
(2,017 Views)
Solution
Accepted by topic author Lenvno

Lenvno,

 

Unfortunately, LabVIEW 8.6.1 is not officially supported on Windows 7 as I think you know. Most of the Windows 7 testing has been done with LabVIEW 2009 and 2010. However, that does not mean that you can't try to install the DSC run-time engine and use this with your executables, but be aware that this is at your own risk and is not supported by NI. For more information on NI software compatibility with Windows 7, please check out this Developer Zone article.

 

Thank you for choosing National Instruments.

 

Chris LS

National Instruments
Applications Engineer

Visit ni.com/gettingstarted for step-by-step help in setting up your system.
Message 2 of 5
(1,981 Views)

Thank you Chris.  I have obtained a 2009 edition of DSC runtime and I am going to rebuild my application with Labview 2009.

Regards,
Len

0 Kudos
Message 3 of 5
(1,977 Views)

Hello,

 

We have some executable applications developped with Labview 8.6.1.  We want to use these applications on a Windows 10 Pro environment. When we start the .exe file  it generates a message "needs runtime 8.6.1 or compatible". Wich Windows 10 compatible version of runtime should we use ?

 

Best regards

0 Kudos
Message 4 of 5
(455 Views)

Is this related to the DSC runtime or simply a normal LabVIEW application?

 

In any case there does not exist any 8.6.1 version of LabVIEW software that is certified to be Windows 10 compatible by anyone, LabVIEW 8.6.1 predates even the release of Windows 7 and NI does not retroactively test software releases for newly released OSes.

 

For the LabVIEW runtime itself it is likely that it works, (I have LabVIEW versions down to 7.0 installed on some Windows 10 systems, although not for production use but just to be able to checkout if I need to know something about them) but NI has not tested it in any way and there is no guarantee that some Windows configurations may not throw a wrench into this.

 

LabVIEW DSC runtime is likely a lot more difficult as it contains many different sub components that might not be compatible with certain Windows 10 features.

 

If it is a normal LabVIEW app you can try to install the LabVIEW 8.6.1 runtime on your machine and see if it works. Note that this is the bare minimum LabVIEW 8.6.1 runtime without any additional components like 3D ActiveX control, HTTP, SMTP, AAL, etc support and such. So it may or may not be enough for your application depending on what functionality it uses. If you need the full runtime installer you have to contact NI support as the only full runtime installers you can download directly from https://www.ni.com/nl-nl/support/downloads/software-products/download.labview.html start with LabVIEW 2009 SP1

Rolf Kalbermatter
Averna BV
0 Kudos
Message 5 of 5
(451 Views)