Showing results for 
Search instead for 
Did you mean: 

Communication problems with the power supply Agilent E3644A

I am having problems communication problems with the Agilent power supply. Using the Agilent test program I am able to set the output voltage. However, when using Labview 7.1 once the program starts running this error message pops up for when it is supposed to set the first output voltage in agilent: "Error -1074130544 occurred at hpe364xa Configure Voltage". The possible reason given for this is:
Driver Status:  (Hex 0xBFFA1190) The session handle is not valid. This program was developed by another student on this same computer and worked. This doesnt seem to be a program issue, but rather a communication between Labview and the Agilent power supply. What could be the reason for this and how can it be fixed? Thanks
0 Kudos
Message 1 of 8
Could you provide a bit more information? What Agilent test program are you talking about? Are you using an NI GPIB controller or someone else's? Are you saying that a program that once worked is no longer working at all or are you trying to write a new program? If it's an older program that is no longer working, was any other software (especially from Agilent) installed after the original program was written?
0 Kudos
Message 2 of 8
The Agilent program is Agilent IntuiLink that I am using. It is not hooked up through the GPIB controller but rather RS-232 to the computer. This Labview program did work and was used extensively, but now when I am using the same program with nothing new installed that I know of or changed its giving me that error. The program starts to run and takes an initial voltage measurement, but once the program gets to setting the output voltage to the device the program shows the error mentioned.

Message Edited by vthokies on 02-13-2008 11:34 AM
0 Kudos
Message 3 of 8
It sounds like there's something about the IVI instrument driver for the Agilent E3644A that is causing this error.  Here is a KnowledgeBase that explains the error and offers a solution: Error -1074130544 or 0xBFFA1190 When Running A Downloaded Instrument Driver.
Also, here is the page for the instrument drivers for the Agilent E3644A on the Instrument Driver Network: Hewlett-Packard / Agilent Technologies E3644A.  The third link is the link to the IVI driver.
Good luck!
Rima H.
Web Product Manager
0 Kudos
Message 4 of 8



I am very interesting in reading the KnowledgeBase article mentioned above, however, I receive a message saying that I do not have permission to read it.  Is there another way for me to get to this information?   Error -1074130544 or 0xBFFA1190 When Running A Downloaded Instrument Driver. 


Thanks in advance!

0 Kudos
Message 5 of 8

Don't know if this will help, but check the serial port settings...maybe one of them is off.  Also, if it's a USB serial port, sometimes they get reassigned.  If you can send it some commands with hyperterm, that might give you a clue.


-Matt Bradley

************ kudos always appreciated, but only when deserved **************************

0 Kudos
Message 6 of 8
I'm getting that error message, too.  So it's not just you.
-Matt Bradley

************ kudos always appreciated, but only when deserved **************************

0 Kudos
Message 7 of 8

The KnowledgeBase mentioned earlier in this thread is not currently live right now, that is why you are receiving an error when clicking the link.  The relevant information from the article is copied below:


Problem: I have downloaded an IVI Instrument Driver for my instrument. After I install it, I get errors when I open and run the Application Example VI. I get error -1074130544 or 0xBFFE1190 saying that the session handle is not valid. Why am I getting this error?


Solution: In many of the Instrument Drivers, the Application Example VI does not include an Initialize VI. It assumes a valid VISA Session is wired to the VISA Session terminal. If you view the block diagram of the Application Example VI, you will notice that the session is not being initialized (or closed). To correct this problem, place the Initialize, or similar, VI prior to the Application Example VI (and the Close VI afterward) and wire the appropriate terminals. This method should allow you to run this example.


This error can also occur if you have more than one Initialize VI in your program. Only one session can be opened to your instrument at a time, so multiple Intialize VIs will produce this error. For example, if you use the Getting Started VI and then place an Initialize VI in your program, the additional session handle will be invalid.




National Instruments
Certified LabVIEW Associate Developer
Certified TestStand Developer
0 Kudos
Message 8 of 8